Throttle stuck

Expected Behavior

The stock firmware of a Herelink Controller Unit should have a straightforward way of centering the throttle for Rover purposes.

Current Behavior

With the current unit I have I am unable to center the throttle so that a vehicle will not immediately lurch forward or backwards upon arming. The current vehicle in question is a Rover utilizing the Pixhawk 2 with the black cube. The Herelink Controller Unit in question is flashed with remoteunit-FRU01200409.tar.gz. The accompanying air unit has been flashed with airunit-AU01200226.tar.gz.

The pixhawk is flashed to Ardupilot via QGroundControl using the latest 4x flash repeatedly over the last week. I’ve tried various settings within the parameters but to no avail.

In previous times with this unit I was able to figure out a way to center the throttle, but I am no longer able to do so.

Steps to Reproduce:

  1. Flash all to stock for Air Unit and Remote Unit.
  2. Flash Pixhawk to Ardupilot using QGroundControl with Chibios for the Rover platform.
  3. Calibrate the built-in joysticks using the Herelink Settings application and save the settings after successful calibration.
  4. Attempt to center the Throttle using the Herelink Controller Unit in the Radio Setup menu.

System Information

When posting bug reports, include the following information

  • Operating System: Herelink Controller Unit
  • QGC Version: 3.0.0-243-gd759437
  • QGC build: Stock from the Remote Unit flash
  • Flight Controller: Pixhawk 2
  • Autopilot (with version): Pixhawk 2 with ChibiOS on Rover with CubeBlack 4.0.0

Detailed Description

Beyond the details above it should be known that prior to the last flash this unit functioned as expected with respect to the throttle control.

Log Files and Screenshots

Looks like you are on a very old firmware. Update it and do the hardware calibration
https://docs.cubepilot.org/user-guides/herelink/herelink-user-guides/upgrading-firmware

Hello @Alvin and thank you for the response. I checked just now via the OTA capability and I’m showing that the system is in deed up to date. It lists my current version as:
SRU01200616.

I just changed over to Beta and will tinker with that and report back what I find. I am curious though, I am updating the handheld unit, but what about the air unit? How do I flash the air unit to Beta, or does it matter?

From what I can see I should be able to update the air unit via the ground unit with this new interface, however I cannot get them paired now to save my life. I am headed out of town for the weekend but when I return I will flash everything to stock and start over again, documenting along the way.

Hi
I had a similar issue and it was the trim for the throttle channel.
I would use mission planner to do the RC calibration and when it prompts you to hold throttle down… this is where it should be mid stick so you get forward and reverse.
In QGC you you can probably manually set trim to mid stick for the RC channel of throttle.
Hope this helps

I thought you were at old firmware because there should be a icon at the topbar as the Herelink Settings App’s notification. It was not there in very early firmware versions.

If you have gone through the hardware joystick calibration, they shouldn’t behave like that
https://docs.cubepilot.org/user-guides/herelink/herelink-user-guides/one-time-setup#joystick-and-hw-wheel-calibration

For the pairing problem, you will need to update your air unit to beta as well.
When using the flasher, put beta behind the command
eg: flasher.exe beta