Toilet bowl with 2.1 black cube!

Hi there:

We just bought 20 black cube pixhawk, 9 are 2018 and 11 are 2019.

We are usign ublox gps with compass, pixhawk and latest 3.6.10 on a F450 dji frame. 4 of the drones (2018) flight nicely in stabilize, loiter and automode (mission planner). But the other 16 have a compass variance issue and present toilet bowl behaivor just after doing an auto-mode flight. Before that first auto mode flight they can fly in loiter mode perfectly. Heading the drone to the north improves the problem, but does not fix it. We are a little bit anxiuos we tried the gps modules with the ones that work well and they keep working fine.

Do anyone have a solution for us??? Have seen some forums talking about this but havent found a solution,


Have you disabled internal compass? Use external magnetometer.

Hi @Mallikarjun_SE , yes i tried that! and problem persists. After first auto-mode and yaw alignment, the compass variance happen again, and could not loiter or flight auto mode properly, toilet bowl show again.

If we start flying with the drone heading to the north it works, but if roll to the south it starts failing.

Post a log. I’ll have a look!

It says new users can not upload attachments :frowning:

Here are 3 logs, I have tried to look for the problem comparing them 2 of these drones work well and the other makes loiter bowls after first autonomous flight.


More details please, photos of your frames, detailed layout etc.

Toilet bowling is a setup issue.

A few things to try…

  1. Ensure your cubes are up to temperature before calibration. Reboot after they are up to temperature.
  2. Use the onboard compass calibration method.
  3. Use latest beta mission planner.

Post logs… you can directly now.

Are you using the SB2 parameters set?

Hi @philip

Ok we didnt use the SB2 paramater set, I tried to find them online was not sure if they were the ones included in the firmware uploading, and we used the parameters from the drones that are flying ok. Do you have a link or can you share this params with us??? And we will try with these parameters.

About the tempreature i did not know about this, which is the temperature for calibration? Where can i see if they are already up to temperature???

And the blog keeps telling me that new user can not upload files :face_with_raised_eyebrow:



ok the SB2 parameter set are these?? CUBE_BLACK.param?? yes we are using them…

i have lifted your trust level, so you can post better :slight_smile: and changed so new users can put attachments

d16.bin (2.0 MB)
d18.bin (2.4 MB)

Hi @philip

These are three logs, d16 and d18 is from drones working well and d20 making toilet bowl.

I cant post the d20 log hahahaha, it says it must be under 4MB

This is from d12 2019-08-18 14-06-32.bin (2.9 MB)

here is another from 12!! hahaha i have tons of logs…

2019-08-16 02-26-42.bin (2.3 MB)

Hi all, we have similar issues but we do not have toilet bowl but the issues are relevant. We have bought lots of Cube blacks and Here1 and Here2 GPS. Here is my findings.

  1. After compass install and calibration the compass points up to 45 degrees off. Change to a differnt Here2 compass (brand new) and it’s off 10 degrees. Change to a different Here2 and it’s off 30 degrees. Change to Here1 and it’s back to normal.

  2. Because of the above every flight there is an in flight compass adjustment reported by the GCS after take off. Drone flies OK after that but “crabs” during waypoint flight. The 45 deg off one crabs 45 degrees, the Here1 is bang on etc.

  3. We also reported that after replacing the Here1 with a Here2 on a known working machine the flight lines are “arcs” not straight lines and it really messes up the photogrametry.

  4. While we don’t have toilet bowl these issues are not good and could lead to toilet bowl and definitely lead to crabbing / in flight yaw alignments that should not be happening.

My conclusion is that the Here2 GPS and compass either have manufacturing tolerance issues, the compass is no good, or firmware is not correctly aligning it.

We have all compasses enabled and always have (there should be no need to disable your internal compass as the external is primary)

We have done enough testing with about 5 drones swapping all hardware back and forth with matching setups to know this is not an installation issue.

If anyone has a line on Here1 GPS’s I want them.

Whoever makes there Here2 needs to look at these issues ASAP please.


hi @UAVS:

Actually I dont have here2 , Im using drotek sirus, buuut they have the same ublox m8p rtk gps. Im not sure if they also have the same compass.

I have 4 drones from 20 flying well (2018 version)(with the same components), have changed the componentes from the ones that are not flying, and they still work. And as you say after take off and trying to do yaw alignment it seems to be an error. We are thinking to use COMPASS_LEARN and see the results.

But I think the fault is in the pixhawk, maybe a treshold or variance fault, trying to do the yaw alignment.

We figured out that when we just upload firmware + parameters + calibration… loitter works fine. But if we try a mission first mission goes ok, but after that every flight in loiter or auto-mode fail… in loiter toilet bowls and in auto - mode strange curves to reach points. Northheading helps but not the solution.

@UAVS drotek sirius gps module has a LIS3MDL magnometer.

sounds like some more similarities.

I have tried compass learn and even after it learns in the air then your disarm, remove power to AP then power back on the compass points way off again and it stays that way until you take off and it adjusts in flight. Sometimes it says ground variance in compass sometimes it just say in flight adjustment.

When you first power on your drone does the compass point in the correct direction? use the compass in your phone to see how close it is. Just make sure you are not near any large metal structures.

We have noticed also that since the fw that fixed the IMU switching the curve to the first waypoint in a grid is good but then it does not do a curve to the next waypoint (which is say only 20m away) this causes the drone to stop, turn then go which is very inefficient and really weird to watch.

here2 specs

@UAVS are u using arducopter firmware right??? Ok Here2 has a ICM20948 compass. So COMPASS_TYPEMASK =256 right?, have you tried changing FS_EKF_TRESH to relax? or AHRS_YAW_P value? It is just what I am thinking to try.

I will check the orientation after flying on auto-mode, and see if there is a variance. What I remember is that both internal and external compass are perfectly aligned. I measured with my phone compass but just after calibrating the first time and it was perfect., but I will try after a flight.