Trouble connecting Cube Orange to computer via USB

Hi all,

I am having trouble installing the latest firmware on my Cube Orange. I can not seem to get the Cube Orange to be recognized as a device when I plug it in to my computer with a USB cable. I have read many forum posts on different ways to solve the problem, but am having no luck. Here is some background information to help with understanding the problem.

  1. I am competent with computers, but this is my first autonomous vehicle build so I may be overlooking something obvious.

  2. I am trying to build an autonomous boat so I am planning to use the ardupilot rover with skid steer. The boat is built and I have the Cube Orange flight controller with an external buzzer, Here 3 GPS, rc control with an R168 and a Radiomaster TX12, telemetry is with a RFD-900x-US ultra long range radio modem, power through a power brick mini, and two Blue Robotics ESCs to two T200 thrusters. All of this is connected and powers up just fine.

  3. Prior to receiving the thrusters I set up the flight controller, GPS, and telemetry in a box to learn about how all that works. I installed Mission Planner on my laptop (Win10) and was able to connect using Mavlink on Com Port15. It works good and I am able to track my self walking around with the flight controller box. All data and maps work great in Mission Planner.

  4. After building the boat and receiving the thrusters, I wanted to update the firmware on the Cube Orange to the latest rover version. When I plug the Cube Orange into the usb port of my laptop, nothing happens. So I, uninstalled Mission Planner and all drivers and reinstalled everything with the latest version. Still nothing. I tried this on my Win10 desktop with new installs of the drivers and Mission Planner and still nothing. I tried installing QGroundcontrol and nothing. I tried to uninstall and reinstall both of these ground control softwares and drivers mulitple times on both computers. Nothing. I tried to plug it into my wife’s Win11 laptop with no software or drivers loaded. Nothing.

  5. In all of these cases, nothing is showing up in Device Manger under the ports or USB connections. I tried this with peripherals connected and disconnected and with the microUSB card installed and uninstalled.

  6. I went back to Mission Planner and connected thru Mavlink and updated the Bootloader. It said latest bootloader is installed.

  7. I tried connecting to all the available com ports with both 57600 and 115200 but none connect.

  8. All firmware updates fail to connect.

Does anyone know what I am doing wrong?

It seems like the Cube Orange is functioning properly thru Mavlink, but it will not connect thru a USB to the computer. I have tried to update the drivers a bunch of times as that seems to be the problem, but not connecting on 3 different computers is strange.

I thank you all for any help you can provide,

Hi James,
I can’t really help you with the details, but I can say that this isn’t the normal behaviour … my CubeOrange is always connected automatically. Sorry to ask the obvious, but have you tried a different USB cable?

I have the same issue with an Orange:


  1. Restarted computer

  2. Tried another computer

  3. Uninstalled/reinstalled Mission Planner

  4. Tried different USB cables

  5. Tried another COM port number

  6. Tried plugging directly into the Cube Orange instead of a USB extension

  7. Tried other USB cables

I am able to connect to it via Tracker so I know it isn’t bricked

ERROR: No response from board

Thanks for the response and suggestion. Yes, i have tried multiple USB cables and just tried another one to make sure that was not the problem. It still does not work.

I hope someone know how to help us. I am wondering if I need to buy a new one and am not really wanting to buy the same problem, but don’t know enough to select a different flight controller.

Hi all,

The problem has been fixed. The suggestion by Björn Opitz turned out to be the issue. I tried an new USB cable that came with a toy for my son and it worked perfectly. So I guess there must be some variation in data transfer capabilities among USB cables. This was the 5th different cable tried, so try a different USB cable if it will not connect.


1 Like

I’ve tried 3 brand new cables and i still cant get it to work