Trouble connecting Cube Orange+ to computer via USB

Hello all,

I am starting a rover project and I purchased a new Cube Orange+ Standard Set (ADS-B Carrier Board). Setting up an Autopilot and flight controller is new to me so I have a step learning curve. I was excited to get going yesterday when I received the Cube. I opened the box and grabbed a USB cable plugged it in and launched Mission planner pulled down the connection selection, and it was not there. I get a steady orange light and no tones when connected. If I hold down the button connected to GPS1 when I power on I also get a green light. I never get any change in device manager when I connect cube with USB cable.

Below is what I have tired without any success.

  1. Uninstalled and reloaded latest Version of Mission Planner.
  2. Tried a total of 3 USB cables.
  3. Flushed the drivers with Ctrl + F and used driver clean button. Downloaded driver.msi and installed.
  4. Downloaded and installed QGroundControl.

Seems like a driver issue, or just a defective unit. What to try next?

I found the solution to this problem. It was the USB cable. I found all of the cables that I had (6). The 5th one worked. The 6th one did not work either. After I loaded the firmware I went back through them all, and confirmed that only one out of the 6 would work.