Trouble setting up landing gear on herelink solex an pixhawk 2

Hi I’m still a newbie with herelink an pixhawk 2 an new solex app. I used run my landing gear on another controller with my gimbal controls but now i want to run it all through herelink. My issue is I set up ch7 to landing gear on gcs which comes out on pixhawk board as Aux1 I set up in solex ch7 as servo set lower an upper ppm 1500 to 2000 but when I press button on herelink controller it goes from 1000ppm to 3000ppm can any body please help thanks

ch7 is not AUX1
CH7 is MAIN 7 and CH9 is MAIN 9

So if I use Aux 1 on pixhawk to connect to landing gear how do I config it on mission planner an then on the herelink to get it to control landing gear

If you use Solex you don’t need any config on Mission Planner.
Go to Solex > Button Mapping > Click any button > set Servo > channel 9, value
It will change the PWM value of that channel when button is pressed.

Thanks Alvin I will give it ago also just so I know the Aux out channels on pixhawk board what numbers do they match in the solex in herelink as your saying Aux out 1 goes to ch9 on the solex app in herelink

ch1-8 go to MAIN 1-8
ch9-14 go to AUX 1-6
notice that you need to change BRD_PWM_COUNT if you want to use AUX 5 and 6

Hi Alvin thank you very much for the info I have tried the setting you said I’m still getting the issue with the pwm value only moving from 1000 to 3000 I’ve setup A button with short press which works fine but when I set value it doesn’t work only moves from 1000 to 3000 an back see attached photos IMG_20200928_200807|375x500

Can you post a video showing so we can see better. Show the settings in Solex and the actual movement.

I will upload more videos tomorrow evening thanks guys for the support

Can you show me the your RC9_MIN, RC9_MAX, and RC9_OPTION value on Mission Planner?
Just to confirm. I have tested on my Herelink, you don’t need to modify those param to move the servo.

Hi Alvin please see photos showing settings

Hi Alvin odd thing now is I don’t have a signal coming out Aux1 now at all which is weird also checking my signal on my remote I saw it said unpaired but remote still connected to pixhawk in solex app an showed data. After seeing that I re bind remote an air unit an now it’s paired. Also when I changed flight mode on the remote it changes but I’m sure I used hear beep on pixhawk board when it changed which I don’t hear now unless I’m going mad also I’m thinking I might have to re flash my pixhawk board hoping I don’t have to.

Hold on

Are you setting this in both Solex and Herelink setting as they are separate.

Herelink settings sets the Sbus outputs to control a channel.

Solex sets the Aux functions to controls a channel.

You need to do one or the other but not both for the same output.

So I would for instance in Herelink settings set up a button for the desired channel ie sbus ch8, Then in Mission planner on Servo 8 set it to RC8 and see how it behaves.

Hi Ian thanks for that yes I was setting both up I will try what you have said above tomorrow evening ill let you no the outcome

Hi Ian thank you very much for your information I did what you said above an now have the landing gear working now an also have a better understanding about how the herelink an Solex talk to the pixhawk many thanks also thank you everybody else who helped along the way.