UDP communication between air unit and herelink with 500.000 baudrate

I want to communicate with my control panel (herelink) and the air unit module in my vehicle via UDP. The config files in airlink seem to be set to 115200 baudrate. I see it doesn’t work when I set it to 500,000 baudrate in the config file. I think I’ve tried all sorts of combinations but it is not working. Now the problem is how can i communicate between herelink and air unit module with 500.000 baudrate. I would be very grateful if you could help.

Can you try if 460800 works?
We have tried that 460800 will work, trying this on your Herelink will verify if your settings are correct.

I will apply your advice. I have set the baudrate settings to 460800 in my own software. In which files do I need to make changes on the air unit and herelink device. Do you have any information about this? I am replacing these files:


I set the baudrate settings in these files to 460800. Do I need to make any other adjustments or am I doing it right? I would be glad if you help.

I have tried almost all combinations. I could not communicate with my system in 460800 baudrate settings. Can you tell me how you run it? Can you share your sample settings files? It would be very helpful if you could guide me on this issue so that I can send the data at this baudrate.

you only need to change mavlink-router.telepathy-air.conf

remove the other options,and put only 460800 as the valid baud rate.

your solution didn’t work for me