Unable to connect with QGC with Pixhawk Cube 2.1

Hello

I bought a Pixhawk Cube 2.1 with a GPS Here 2 and I am unable to connect with QGC. I tried different cables and different OS (Mac, Linux Windows) and it still don’t recognize it.
I tried the daily build of QGC but no difference.

It work perfectly fine with another Pixhawk Cube 2.1. When I do Device Manager on Windows, it saw the pixhawk there is also the caracteristic sound (see picture attached - sorry it’s in french)

I saw that the COM name is not the same for the two Pixhawk :

  • the one working -> PX4 FMU (COM4)
  • the one not recognized -> PRofiCNC CUBE F4 FMU (COM11)

It is possible to be an driver problem ?


Hope you can help me

Best!

Exactly the same problem here, also recognized as CUBE F4 FMU. Connects fine with Mission Planner. But not with QGC on same winPC. But connects ok with QGC on Herelink ground unit.

Finally the problem was that the Pixhawk was sold without the firmware. The only way to flash it is to use Mission Planner and do the Initial setup. After, you can use the Pixhawk with QGC.

The procedure is there :
https://hexadrone.fr/blog/pixhawk-cube/flasher-un-cube-pour-sa-premiere-utilisation

first… All cubes are shipped with no firmware… it is 100% your responsibility to determine if the code you add is satisfactory

second, you will see we recommend mission planner. use mission planner… if you must use QGC, and you find a bug in QGC like this, report it to QGC developers

I have the same “problem”. I have flashed Copter 3.6.10, and then Copter 3.7-dev on my Cube Black.
It connects fine with Mission Planner, because you actually tell the software with port to use, but with QGroundControl, it doesn’t connect, because QGroundControl tries to auto-detect the Cube. If you set up the connection manually, it WILL connect to QGroundControl too.
I don’t know if this is a driver problem, or a QGroundControl problem…

Are you running the very latest QGC? If yes, then best contact the QGC team and they may be able to assist.
In the meantime, please use Mission Planner

Yes, latest QGC. I’ll contact them.
I am anyway using Mission Planner more often…I just like to have consistency in the interface, and when I use my tablet as GCS, I use QGC, this is why sometimes I use QGC on my PC too.