Unable to stream video, code 404


I’m still having problem with the Camera 2 on QGC and solex

It’s very hard to make it work, a lot of reboots, and sometimes works.

Any solution?? Thanks


What camera are you using? Does it work on HDMI1?

Im using an analog to HDMI converter. On the Camera 1 works at the first turn on, but on Camera 2 wont.

Can you verify if the HDMI to Herelink is 720p@30fps or 1080p@30/60fps?
Also, are you using both hdmi port or switching between them?

You can also try to connect a laptop to the HDMI port on Herelink via HDMI-microHDMI cable to check functionality.

Im usging 1080p@30/60fps
Just port 2
I Will try to connect the computer, we already found a way to connect the camera to the port 1 on that drone (space problem), and that way works jusut fine, so we already delivery those.


I have faced similar issues.
My setup is with a GoPro Hero7 Back at 1080p/60fps/Linear connected to HDMI 2 only.

The simplest way I have found to work around this issue is to switch to camera 2 and if the error pops up, just go back to launch screen and come back to video view. Most times it starts streaming.

1 Like

thanks! yes, most of the times works, but some times, doesnt work at all.

I’m about at wit’s end with Herelink and the cube in general…
I have been trying all two options presented to make a gopro hero 3 work with herelink, and even re-flashed the vehicle back to ardupilot just to solex would work, but still no joy. Are the only troubleshooting options really just repeatedly plugging and unplugging your camera and verifying you are in 1080p 30/60?

I’ve been working with ardupilot since 2009, and was so hopeful for the cube and herelink to be a viable solution, but have been disappointed at every turn. 3+ weeks wasted now with no answers to any of the problems in this feed.

If you can get the stream from HDMI2 sometimes, it sounds like a software problem.

Can you generate a bug report?

I’m having this issue as well. Haven’t been able to get it to work whatsoever…

Tested with a GoPro hero 3 (which, supposedly, is compatible) and my HDMI out on my computer, neither with any success. Tested on both HDMI in ports on the air unit. The rest of the Herelink seems to be behaving - I can get good telemetry and RC to/from the aircraft.

Any news/troubleshooting? I’ve seen some reports that the Hero 3 doesn’t play well with the Herelink although it’s listed in the compatibility post, should I try to get another camera to test with? I know the camera itself is fine, it can output to a regular HDMI monitor.

You can try to connect Herelink to a computer HDMI source. Projecting screen from computer to Herelink works in most of the time.

By doing this you can verify whether it is Herelink’s problem or camera compatibility problem.


Yep, tried that. HDMI out of my laptop works fine on a regular HDMI screen, but got nothing on the Herelink. Same error as with the GoPro.


Try to reflash the firmware on both controller and air unit.
Verify the resolution of video output.

If none of these fix it, contact your reseller for RMA


Unfortunately, neither of those resolutions fixed it. We were able to get it working with a Hero 7 Black however, which supports my hypothesis that there’s something odd between the Hero 3 and the Herelink.


It’s weird for your Herelink works with specific camera but not with computer…

please see latest beta and confirm this fixes your issue

1 Like