Unhealthy AHRS, pre-arm accels inconsistent and Overheating IMU

Hi there,

I tried to do a flight today with my VTOL running arduplane 4.0.5. I flew it quite a bit before, about 40 flights without any issue, but today, when trying to takeoff, I had the message pre-arm accels inconsistent. after taking back the VTOL inside, I touch the cubeblack, the outside was very hot, I could cook an egg on it.

After plugin it in via USB, I saw the message Unhealthy AHRS for about 8 minutes before disappearing.

When I checked the log of the flight I tried to do, the IMU 1 and 3 gave me a max of 81.8 degrees C :astonished: and IMU 2 gave me 0. The max on the last day of successful flying was 65 degrees C

When digging deeper, I found out that IMU 2 Accelerometer on the axes X, Y and Z was very noisy like this :

IMU Problem

BRD_IMU parameters are factory ones, I did not change them.

So is this a RMA case? Could I possibly disable IMU2 and do you think it is safe?


Benjamin MATHON

Ok. I found why. It’s because the the drone stayed 30min on the ground while connected, the cube is under a cover and close to an Emlid M+ which can get very warm. The heating elements stopped working after reaching the target temperature of 45 degrees C.

Now the question is, Can I safely use this cube again, since it reached a temperature of 82 degrees C?


Did you find the answer? Thanks.