Unkown flight mode

I checked for a support forum for SoloTX… Not much help unless you own a wood stove. So in Solo TX, all flight modes show up on the TX as unknown. Is there some setting to fix this? Solo knows it’s a rover, but doesn’t understand the different modes. When I go back to copter, it works as normal.

What firmware are you using on the autopilot? My Ardurover works fine with Herelink.