What to do when autotune is not the answer

Hi guys. My build is big QUAD, 28 inches folding prop, T-Motor Alpha 60 A HV ESC, T-motor U8-II, 12s cells battery, cube ORANGE, Herelink controller, firmware version COPTER 4.0.7.

I have followed the step by step procedure in this link (Tuning Process Instructions — Copter documentation ), as I have done plenty of time in the past with good results, even in larger drones. However this time, even in a windless scenario, I am not able to get a good tune after running autotune with default aggressiveness (which is the maximum). Look at these logs… even in the log corresponding to a flight in no wind scenario, real vs desired performance is not good at all (logs – Google Drive). Looking at the reasons of what an Autotune may fail:

  • High levels of gyro noise: not in this case
  • Incorrect value of MOT_THST_EXPO: it was derived from ground test, and also compared to manufacturer data
  • Flexible frame or payload mount: nothing, the vibration performance of this dron is very good
  • Overly flexible vibration isolation mount: cube is hard mounted
  • Non-linear ESC response: MOT_THST_EXPO was 0.15 meaning almost linear
  • Very low setting for: motor start to spin at 0.04, son we set MOT_SPIN_ARM=0.06 and MOT_SPIN_MIN=0.09
  • Overloaded propellers or motors: MOT_THST_HOVER converge to 0.33, which is low

Having ruled out the previous sources of issues…. Here there are my questions:

1- Can anybody tell me if we are setting any parameters wrongly before AUTOTUNE (in the drive you can find params before tune)?

2- Is there any other not-listed issue that may be affecting my build?

3- What to do when autotune is not the answer? Any advise on how to proceed from this point?

I’m not familiar to tuning but I’ve heard autotune may not results good tuning on big vehicles. The solution is to manually start a basic tune -> invoke autotune -> manually fine tune.
Basically the Tuning page in Ardupilot wiki
And they have instruction about what to do if autotune fails. Not sure if you have tried it

@Alvin, Unfortunately @juan.gonzalez cross posted so we have been discussing this in ArduPilot. I think he is a new user and does not realize the support people read all of the forums.

The size of vehicle that @juan.gonzalez is describing is no longer considered “large”. The autotune works very well on this size of vehicle (and on much larger vehicles) provided people follow the instructions in the wiki and set up the autotune appropriately for the size of the vehicle. In this case @juan.gonzalez needed to turn down the aggressiveness parameter go get better results.

Hi CraigElder. You are right, I always posted in both CubePilot and Ardupilot forums just in case, but as you says, it may be better to just post in one them (kept in mind for next time).

After all your feedbacks, I think the steps to follow are:

  • Set dynamic notch filter to reduce gyro noise
  • Repeat Autotune setting aggresivenness to 0.075

Just to mention, none of previous advise are directly extracted from the wiki, instead of that, they were derived from your replies and assitance from the forum. So, if I finally fix the problem following the mentioned actions, it may be useful to include some words regarding this in the Tuning Process Instructions Wiki page.

You are correct. The wiki is one of those features that everybody benefits from and nobody wants to pay somebody to maintain. Consequently the wiki always lags. Since the demise of 3D Robotics in 2015 the wiki has been exclusively maintained by volunteers. Our volunteers do an amazing and difficult job.