Wheel issue/defective - please help

I have issues with my wheel.

I guess it’s because of the potentimeter/variable resistor. The same issue is present if the board is not present.

Is it possible to aquire the board or get the part number of the variable resistor?

Here is a video of the issue:
https://drive.google.com/drive/folders/1oStSLWppnmqqwyjPhs2OkKEXurbWI9IY

It seems to me that there are different version, is there a more reliable one?

Please contact your reseller for RMA.

Just want to confirm one more thing if you have not send it back.


Did you find the fell off metal housing of the potentiometer inside the Herelink case or anywhere?

1 Like

No could not find a part inside. The only strange thing was a loose antenna mount screw.

This HereLink seems to have another type of potentimeter. From the images within this forum I see that there are the white/metal one, out defective one is brown an smaller. Maybe the brown one is more robust in the end?

The behavior stays the same regardless whether the board is removed or not.

Since the fawn rescue season is starting in 4 weeks and last time I did send in an HereLink it came back after weeks and had scratch marks all over it, I would prefere a spare part rather than sending it in.

I have searched for sometime but cannot find this variable resistor type online. I would also change it on my own or replace it by another switch with custom resistors - I just would need some more information on the part.

We have tried to replicate the problem and it requires prying with tools, not even possible with bare hand. I don’t think anyone had damaged it.

This is not another type of potentiometer. That’s the internal of normal potentiometer.

As the problem on your unit is pretty clear, you may ask for a replacement board from your reseller. It is quite easy and risk free to replace the joystick controlling sub-board.

1 Like

Ah, ok, thank you, that makes a lot of sense. Sorry for the confusion!

I got that unit back from a customer and the wheel did not work. It did work when the unit was delivered though.

Ok, than there should be that part somewhere inside the HereLink? Any ideas where it could be hiding?

That’s strange. If it worked, that part must be intact back then.
The Herelink controller is closed with no opening. It must be somewhere inside, but I can’t really tell the exact position.

btw, the potentiometer is SVM4A103A0L17R00
https://www.murata.com/zh-cn/products/productdetail?partno=SVM4A103A0L17R00

It might have degraded over time beeing loose in the beginning and getting lost after some time. It might be possible to trace that within the flight logs I guess… .

I want to thank the team, I received the replacement part and everything works great again.

Thank you very much for your help!!!

1 Like