Yellow cube Problem Heating / IO board error / Can’t read RC

I’m use Yellow cube and latest firmware.

but there is still problem.

I upload use Qgroundcontrol and latest version v1.11.3(see following picture)

but there are some problem, see following picture

Is everything all right?
Am I the only one? …



Firmware verision


  1. heating problem.
    Yellow cube so hot, and it’s temperature up to 61.7 celsius.

  2. I/O Board error.
    occurred I/O board error

  3. Can’t read RC

What firmware are you using ?

PX4 or Ardupilot ?


I used PX4 firmware v1.11.3
I tried v1.11.2 also
both version occured that problem.

I would speak with the PX4 team as it’s their software that’s the issues. Ardupilot is fine.

Thank you for your cooperation. I’m CTO of Pablo Air, Co., Ltd, and we had purchased 100 units of Cube Yellow last year. Our purpose is to operate based on PX4 firmware to prepare for the discontinuation of Cube Black.

However, nearly a year later, we have not solved the PX4 problem and have not been able to use it. @philip @MadRC Is there any way you can help us more actively?


My advice to you is to not use PX4!

Even though there are some great people in PX4, their upper team management is very caught up in the commercial world and they are directly restricting access to code to people that refuse to pay very large service fees

I wish there was something I could say that would make it better however sadly you have fallen into the cracks of the new direction PX4 has taken.

Philip, Cubepilot and all the others make hardware that is open and available to be supported by anyone who wants too. It’s then down to the Devs to add support if they want too or not. It’s nothing new and both PX4 and Ardupilot has been doing this for years.

Sadly PX4 has moved to a more paywall approach to development imo and as it’s now directly supported by some specific hardware manufactures and as such they appear not to be developing much outside that hardware as much now. While they have added support for the Yellow PX4 have left it half baked it seems. I’m not going to say if that’s intentional or not as I don’t know but they have not actively fixed the issues even though support is there. While PX4 will say it’s open and anyone can put in pull requests it’s core Dev teams don’t appear to be doing that for all the available hardware.

This is where a key ethos difference between Ardupilot and PX4 kicks in. While some vendors support Ardupilot financially the Dev team go out their way to make sure all supported hardware works as or should even for those who don’t support financially. If they choose to support the hardware then they want it to work 100% and they will fix any bugs brought to their attention.

PX4 seems happy to put a half baked implementation in and let the users suffer the issue.

I would and am strongly saying everyone avoids PX4 right now as they have a lot of things to improve before normal users should be trusting them to support them in the future.

I would open a pull request with them on the issues and see what they say. I’m not affiliated with Ardupilot, Cubepilot Ardupilot or anyone else for that matter so my comments are based on how I have seen and experienced things my self. Right now there is not at lot to like about PX4 unless you willing to pay for Enterprise.

Thank you for your advice.

I got to know many new things. Thank you.