Air Unit Update and Pairing

Hi,

I recently purchased a Herelink system (in early August) and had yet attempted a pairing until today. However, before initiating a pairing, I successfully updated the firmware on the Remote Unit (Tx) from the unit itself. Then, following the instructions online and from Mad’s Tech video, I attempted to update the firmware on the Air Unit using the flasher_win software (on Windows 10).

Steps followed:
-Powered the Air Unit with with either a 2S or 3S battery,
-Plugged a micro USB cable into the air unit and then computer,
-Extracted and ran the flasher_win software.

PROBLEM: The software does not recognize the Air Unit and simply cycles through “Looking for Device…”. I have Google USB/ADB drivers installed and can verify proper operation with other devices. Unit is powered (LED2 is lit) and I’ve tried multiple USB cables (including the one provided with the system).

For the heck of it, I tried pairing the Remote Unit and Air Units, but the pairing failed after a dozen or more attempts. LED2 will flash but eventually turn solid after the Remote Unit times out. However, I suspect this may be due to a possible mismatch in firmware. Any thoughts and/or advice regarding my failed attempts to update the firmware on the Air Unit would be greatly appreciated.

Peter

1 Like

Did you hold the pair button before powering it? after that, you can connect it with usb cable and update it.

Thanks, Bilalakhtar! After posting, I tried the Fastboot option on the air unit to no avail. Problems were similar as stated in here:

Using “adb kill-server” didn’t help. What worked in the end (for me) was installing Zadig USB drivers. I’m guessing the clockworkmod drivers mentioned by Andrew Bostaph in the above post would have worked as well.

And as predicted, once the firmware matched between units, I was able to pair the devices without any trouble.

Thanks!

P

Hi this
i have the same problem this is what i get in the flasher_mac comman
please help

Last login: Mon Aug 23 14:11:07 on ttys000
/Users/nev/Downloads/flasher_mac ; exit;
Nevilles-iMac:~ nev$ /Users/nev/Downloads/flasher_mac ; exit;
Looking for Device…
Found Unit Type: airunit

Downloading required package…
Traceback (most recent call last):
File “urlgrabber/grabber.py”, line 1583, in _do_perform
pycurl.error: (77, ‘error setting certificate verify locations: CAfile: /usr/local/etc/openssl@1.1/cert.pem CApath: /usr/local/etc/openssl@1.1/certs’)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “flasher.py”, line 265, in
File “flasher.py”, line 73, in download_package
File “urlgrabber/grabber.py”, line 828, in urlread
File “urlgrabber/grabber.py”, line 1298, in urlread
File “urlgrabber/grabber.py”, line 1170, in _retry
File “urlgrabber/grabber.py”, line 1148, in _retry
File “urlgrabber/grabber.py”, line 1281, in retryfunc
File “urlgrabber/grabber.py”, line 1346, in init
File “urlgrabber/grabber.py”, line 1695, in _do_open
File “urlgrabber/grabber.py”, line 1833, in _do_grab
File “urlgrabber/grabber.py”, line 1829, in _do_grab
File “urlgrabber/grabber.py”, line 1678, in _do_perform
urlgrabber.grabber.URLGrabError: [Errno 14] curl#77 - “error setting certificate verify locations: CAfile: /usr/local/etc/openssl@1.1/cert.pem CApath: /usr/local/etc/openssl@1.1/certs”
[32008] Failed to execute script flasher
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.

[Process completed]

Hi Neville,

Your issue is a bit different than mine in that I wasn’t able to initially connect to the air unit. Here, it looks like you are able to connect to the device (i.e., drivers are good), but now pycurl is having trouble pulling the appropriate software from the servers. Unfortunately, I cannot help you with this and would recommend starting a new thread highlighting the problem with flasher_mac in case others might have insights for you. Best of luck!

P

Did you supply power to the power port on air unit? or did you just connect it via USB?

1 Like

dear Alvin ,

Yes, using an 8 volt power

Using USB does not turn on the Led at all

Does it show up in lsusb when you connect it to your computer?

image
In my machine it shows up as a blank, as only its internal storage auto connected.

If you have a windows computer, you may check the COM port as well.

Hi I have come right with my two units and is updated and working 100%
I had two make a folder in my C drive and load the flasher in too that file, unzip it in to the same file.
First connect the air unit power 6v to12v and plug the usb in the air unit and then into the PC and then
opening the flasher.
This is the same as for the Herelink radio to.