Anybody got video on GStreamer?


Should video display via GStreamer work?
I have a Mission Planner installed. In Video I have the option Herelink but does not display anything
I do have Video on my desktop when running QGroundcontrol



You may want to check the following thread of Ardupilot.

Download and install the latest version of gstreamer should solve your problem.

@champ8242 Sorry for my last reply. Download and install the latest version of gstreamer only solve the gstreamer error, but cannot get the HereLink video to be played on MP. At least this is my current situation.


Thank you for your input and update. I have been busy debugging the situation also with your remark of the download. I immediately checked the version of GStreamer I had installed and it is/was the latest 64bit for Windows 10. I will report later in this thread my findings

Just FYI

Thanx @Steven

Lets get some entries on how to get Herelink working with MP. I have updated my GStreamer to the latest v1.16.2.0. That didn’t help


@champ8242 As I mentioned in my previous reply, I have done the same without any success.

In addition to update the gstreamer (which did solve the gstreamer error problem), I have also tried to change the gstreamer source to – rtspsrc location=rtsp:// ! application/x-rtp ! rtpjpegdepay ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink

You may want to give it a try, but this did not work for me either, unfortunately.



There is a mismatch in your source:
ERROR MissionPlanner.Utilities.GStreamer - gst_parse_launch: could not link rtpjpegdepay0 to videoconvert1

The source in the MP code (that does not work as well) is:
rtspsrc location=rtsp:// latency=41 udp-reconnect=1 timeout=0 do-retransmission=false ! application/x-rtp ! rtph264depay ! h264parse ! queue ! avdec_h264 ! queue leaky=2 ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink sync=false

One would think this was tested.


@champ8242 Interesting. Because I did not get any error message from MP with the source I used.

Confirmed the source setting you mentioned did not work either.