BETA updating problem?

So I am updating firmware following the wiki. I did the Air Unit first an it all seemed to work nicely.

Now I am trying to do the Remote and it doesn’t seem to be doing anything! I restarted my system and ran the ADB service command again. Plugged in a powered on the Remote, which the computer recognizes as “Optimus” (no errors in the device manager). (Windows 10 system btw)

I’ve double clicked the flash_all_except_data_storage.bat and all I get is the command prompt with:

C:\HERELINK>fastboot getvar stage 2>&1 | findstr /r /c:“stage: romboot” && fastboot boot C:\HERELINK\images\firstboot.img &&

…and that is where it stays.
I’ve tried restarting my system several times. I’ve tried updating the Google USB Driver. I’ve tried both versions of the firmare (2.1 & 2.2) including the flash_all.bat option with the same result.

Now I’m a bit lost. Am I just being impatient and should I be waiting a long time for it to do anything?

Any help greatly appreciated as I’m guessing now I’ve updated the Air unit the two won’t connect anymore…



Now I’ve also turned usb debugging on and changed USB connection to MTP (also tried PTP).

Still nothing :frowning:

Have you read through this thread HereLink-Beta
I was having a problem with drivers.

Just to confirm you have downloaded the separate firmware files for the ground unit and placed all the same tools in again ?

1 Like

Hi Cameron,
Yes, I tried that one. I followed the video (although on Windows 10) and it told me those drivers weren’t for a 64 bit system. In device manager it does recognize the device though and I am getting no warnings.

Yes, I created a folder in the C:/ drive and put the platform tools and firmware tools in together. I did this with the air unit first and it updated okay. I then restarted my computer, deleted out all the files and put the platform tools back with the remote firmware and ran through the whole process again with no luck.

Got it!!!

Okay, so the key was to power on the remote and put it into USB debugging but leave the USB connection type as charging only.
THEN start the ADB service so it recognized the remote as an ADB device.
Ran the batch file and it is processing now…

Odd, at least you have sorted it.

I’m having the samen problem , but can’t fix it . Very frustrating

I imagine it wasn’t that complicated. I was just being a bit of an idiot. :crazy_face:

I’m not sure it was the drivers in my case. I think it needs to be in USB debugging mode (you’ll need to enable developer tools) and the USB connection type set to “Charging”, not MTP or PTP.

Oh, and make sure you have the correct firmware file and platform tools in the same folder and have run the ADB service thingy.

I’m pretty sure it’s a driver issue cause de adb commands aren’t recognized but i can’t update the driver because there not 64 bit. Tried everything and had enough. I’m going to try with a Linux system. Grts.

I thought that too. In device manager it said Optimus was an MTP media device. I think I uninstalled it and then plugged it back in after making sure it was in the charge only USB mode.
It took me all night to get it right so I understand the frustration!
PS. If you do get it to work, make sure you “flash all” on the air unit otherwise you’ll never be able to re-bind them!

HI all. I have had a series of issues with updating the Herelink with the BETA firmware. All was working OK before the update. I used the flash_all_except_data_storage.bat file. I only updated the Ground unit though.

First after what seemed a successful update the “waiting for Vehicle Connection” with no data rates displayed. It did successfully pair but I still could not get a connection.

After reading of some of the problems in the thread I repeated the process using flash_all.bat . It required me to pair and started a countdown but I could not get to the Air module pair button in time. The countdown expired. I restarted the Herelink ground controller and now get a permanent message “WARNING Please long press the Pair/Reset button…” which will not go away. Pressing the Pair button for over 3 secs makes no difference. Restarting does not help. I am stuck. Please advise.

if you updated the controller, you should also update the air unit (‘flash_all’). after that you will be able to pair

OK, I will try that. My concern was the controller seems to be hanging with the “WARNING Please long press the Pair/Reset button…” message which is impossible to clear. It does not lapse after the 30 secs.

Good news. updating the air unit worked. I was concerned that USB seemed to be connecting and disconnecting when I plugged into the Air unit, but it updated without issues. The controller paired. Many thanks.

1 Like

I had that too with the USB. It kept connecting and disconnecting, then opening my Sony Play Memories thing. I just had to time it right to hit the flash_all script and then it settled down!