Can solex tx only control aux outputs? Can I use main out for controlling my gimbal through solex tx in herelink?

Hi @Alvin @MadRC @philip

Can solex tx only control the aux outputs of my pixhawk cube orange or also the main out pins of my pixhawk cube orange. I want to use the main out for controlling my gimbal through solex tx ? Is it possible ?

Hi @Alvin @MadRC @philip

Can solex tx only control the aux outputs of my pixhawk cube orange or also the main out pins of my pixhawk cube orange. I want to use the main out for controlling my gimbal through solex tx ? Is it possible ?

Read the ardupilot wiki. As long as you handle the parameters well, MAIN and AUX are no different.

use the settings app on herelink to control what sets up the gimbal

But if I use settings app on herelink to control gimbal, then I cannot use the roll wheel to multiple servo outputs like in solex tx. In solex tx, I can set the gimbal wheel default as ch:9 which is aux 1 on cube and a short press to change wheel settings to ch:10 which is aux 2 on cube and a long press to clear wheel settings. So ch:9 is pitch and ch:10 is yaw in my gimbal. Can I do the same things in herelink original settings?

then use the Solex settings… it’s your choice

1 Like

Thanks you very much for helping me. :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face:

Hi there,

The reason I am reluctant to use RC with the herelink is because I wont be able to get gimbal control. It seems only my SBUS 1 works. So if I plug in the sbus 1 cable into my FC, then I get RC control of my drone, but if I plug SBUS 2 into my gimbal (ronin s) I get nothing. However, if I plug in SBUS 1 into my gimbal, I instantly get control of all axes with no other effort put into doing so. The ground controller joysticks instantly control the gimbal axes as well as start/stop record. I get nothing through sbus 2, even after remapping the scroll wheel to any channel 17-32. No control at all for any of the 3 gimbal axes, nor start/stop record. I can track the ppm/sbus values on the app for my gimbal, and it is responsive and shows values when using SBUS 1. When using SBUS 2 cable, after trying out every channel 17-32 on the scroll wheel (and pressing save after every change), I get nothing. Is there a detail I am missing to be able to set this up All I need to be able to do is set up one gimbal axis onto the scroll wheel and Ill be set. I will have control of my drone through the joysticks and my gimbal tilt through the wheel. But I cant seem to get the wheel onto anything, and yes I have calibrated it and it accepted the calibration meaning it knows the wheel is there.

Any help is appreciated.


The first 16 channels are S.bus1, the second 16 are s.bus 2

Yes as I mentioned I understand that. I am getting no reaction from channels 17-32.

are you sure you have the latest firmware on the herelink, and herelink air unit?
are you setting the system up in the herelink settings app?

I can double check, but I do remember installing an update for the ground controller when I received it about a month ago, and installing an update to the air unit just this past weekend. Where exactly should I go to confirm those versions with you or someone else so I can see if I did that correctly/am up to date?

As for the channel setup, this is roughly what the page looks like except with the 32 channels displayed on the right. I mapped the wheel channel through here for channels 17-32 and got no response from sbus2 into my gimbal, although sbus1 worked just fine with my gimbal so I know that it is not a compatibility issue (gimbal designed specifically for SBUS input anyway)
Is this what you mean by the “herelink settings app”? just clarifying.

please update your controller. you are on very old firmware

thats not my controller lol. i was just giving an example of the screen. you didnt answer any of my questions

Can you take a screenshot of your settings screen? you didnt mention that the screenshot was not yours

Sure thing. My bad for not clarifying. Here is a photo of my own screen. As you can see on the right side are all channels 1-32. What im trying to say is that I have tried to map the wheel (W) to channels 17-32, I tried them individually, saving settings each time with the green “save” button on the top left corner, then moving the wheel to its maximum positions various times and the channel slider moves on the screen (shown in the picture), however no reaction comes from my gimbal. This is when im plugged my gimbal into sbus 2. However when I plug sbus 1 into my gimbal, I instantly get control using the joysticks, which I believe are channels 1, 2, and 3. Nothing comes through when im plugged into sbus 2, just the slider moves on the screen shown.

can you do an air unit bug report whith you moving the wheel while it is set as 18

Sure man, how do I do that?

You may check the procedures here:

Thanks. I will do the bug report when I get some time this weekend. However I am having a thought right now: Since my gimbal is instantly responsive through sbus 1 channels 1-6, and it is mapped technically from factory settings to sbus channels 1-6 (cant change that), maybe that is why it wont respond to channels 17-23 with sbus 2, even though those are the “channels 1-6” of sbus 2. Does that make sense?

If so, is there a way to re-code the herelink system so that I can use channels 1-6 with the gimbal through sbus 2, and channels 7-11 I can make the autopilot control axes (roll, throttle, pitch, yaw)? I know that they are currently set to 1-4 and cant be changed.