Cannot Pair Air and Ground unit

I have tried all the suggestions that I have found on this site. My Ground unit has been updated to (BRU01210730). I tried to run the flasher_win program on my air unit. I have the air unit on 12 V regulated power from a BEC, I plug it in and the unit powers up (antenna are attached). When I try to run the flasher_win, a cmd window opens, flashes very quickly with text, then automaticaly closes. I have tried this on 3 different windows computers with the same result. I have even run it in admin mode with no change. When I try to pair the LED 2 light flashed on the air unit and the ground unit tries to Pair, but I keep getting a message saying that Negotiation timed out and to try again. Any ideas? Any way to check the firmware on the air unit via the USB cable? Any idea why flasher_win will not show me what I am doing? I have disabled firewalls, put the ground unit in Airplane mode, tried powering it at 5 V, 6V, 12V…this is very frustrating…

Do not start flasher_win by double click. Start it from the CMD command prompt window. The you can see if it is flashing the air unit correctly or not. I assume that it is not flashing correctly.

Thanks Sven…that allows the CMD to not close here is the error:

Looking for Device…Traceback (most recent call last):
File “”, line 260, in
File “”, line 142, in detect_until_found
File “”, line 241, in detect_unit
File “site-packages\adb-1.3.0-py3.8.egg\adb\”, line 255, in ConnectDevice
File “site-packages\adb-1.3.0-py3.8.egg\adb\”, line 221, in FindAndOpen
File “site-packages\adb-1.3.0-py3.8.egg\adb\”, line 117, in Open
File “site-packages\”, line 2168, in open
File “site-packages\”, line 133, in mayRaiseUSBError
File “site-packages\”, line 125, in raiseUSBError
usb1.USBErrorNotSupported: LIBUSB_ERROR_NOT_SUPPORTED [-12]
[17100] Failed to execute script flasher

Looks like a flasher error? I put Flasher in a root folder on the C drive per other instructions on here…is this thing bricked or any recourse?

Another thing…on the air unit only LED2 is ever illuminated. LED1 never lights up. LED2 is amber solid unitl I try to pair, then goes blinking green back to solid amber.

Yes. Flashing fails. As it is not detecting the air unit I assume this related to missing/incorrect driver. I will search in my older posts where I described how I resolved it.

Greetings Sven, I found a link to DriverStore Explorer in another post of yours. Updated the Google driver and then I could get firmware to update and with the updated firmware I can pair. This is highly non-intuitive, and I thank you for your help.

This is the thread that worked for me. Thanks again Sven!

Good stuff :v: