Compass not calibrated

I need your help. I have two Here2 configurated on can1 and can2 ports. Even though I have calibrated compasses successfully. I get message “Compass not calibrated” or “compass inconsistent” at start up. I still get this messages even if I calibrate the compasses again. Also the compasses constantly switching between 1, 2 and 3 when flying and HDOP is high. I had to raise it to 200 to get through prearm checks.

I run latest MP and copter 4.0.3 on a Cube orange and also updated both GPS. I can see both GPS has a id in HW page and also both GPS1 and GPS2 show up on MP fly window. Both GPS get 3d fix sometimes and sometimes I only get the messages above. Any ideas what is wrong? Thanks.

Are you using GPS blending with them?

I have tried both blending and use best. In blending the copter toilet bowl when holding position and in use best it constantly changes compass and even loose the compasses.

GPS blending on both CAN GPS is not ready yet.
You may use either 2 I2C GPS or 1 CAN GPS with 1 I2C GPS

Ok, is that also when using two CAN GPS in “use best” mode?

Hi again,
Seems like others also have similar problems as we do with Copter 4.0.3 and Cube orange like high HDOP, compass calibration problems, compasses that dont show in HW page, pre arming checks. Should we go back to earlier versions of Copter and maybe use Cube black again and wait for problems to get solved? Problems started with Cube Orange. Is this known problems with Cube orange?

/Magnus Abrahamsson
Adrone Services

As long as you are using this feature
,you can’t use both GPS with CAN.
This problem will be solved in future versions of ardupilot and is a software problem.