Cube Black / Here GPS Compass calibration issue

a while a ago I had a crash with my copter* and my Cube Baseboard got damaged. I replaced it and repaired the Here GPS antenna (the case). The Cube itself looks undamaged.

Today I went out for some test flights but I always got a bad compass and no arm.
After recalibrating the compass it worked 1-2 times and I was able to fly a small mission. After unplug/replug the battery same issue. I could only solve it by compass calib but not all the time. It was quite cold today so maybe temperatue could be an issue, too.

Is it possible that the Cube have any issues related to the crash? On the other hand I tried only using compass 1 (the one from the cube?) and only compass 2 - same behavior. I have no more ideas how to solve this.

Any help is appreciated.
Bye Jim.

  • Cube Black, Here GPS, ArduCopter 4.0.3, MissionPlanner

The internal compass is most applications can be disabled as unless your frame is designed specifically to accommodate it you can get all sorts of problems.

I would disable the internal compass recalibrate the external one and then try again.

Hi Ian,
thanks, willt try this later the day.
In Ardupilot:
Disable Compass 1
Enable Compass 2 + Check “mount external” box ?