Cube Black stuck at bootloader while connecting to KISS ESC via AUX Port, Copter 3.6.12

Hello everyone,

I built a quadcopter with KISS ESC and I want to use it with Cube Black FC. I followed this tutorial for setup ESC with DSHOT:

However, when connecting ESC to AUX Ports of Cube Black, the Cube didn’t boot completely most of the time and Ardupilot didn’t start at all!!! Specifically, the orange LED of the Cube Black flashed continuously, and then when I connected the USB cable it mounted a different COM Port (COM8) instead of COM9 (when it boots normally).

Additionally, the Cube will boot normally all the time when I remove ESC connections to AUX Port or when I connect it to Main Port to use PWM. I tried two Cube Black and two ESC units but I still have the same issue.

Could anyone give me some suggestions or show me how to find the error during booting of the Cube? I would very much appreciate any help/comment!

Notes: I originally posted at Ardupilot Forum, but duplicated here because this is Cube Black specifically issue:

Thank you!

Looks like an ardupilot issue, so let’s follow it over there for now.

Hi @philip,

Thanks for your comment! Is it possible to see any error message while the Cube is blinking orange continuously? Is there a boot log or something similar so that I can check why it didn’t boot up normally?

Can you connect mission planner to it?

If it’s blinking, that’s the FMU B/E led indicating it’s in bootloader mode, so no firmware is running and you have nothing to connect mission planner to.

That KISS is doing something to the FMU it’s directly connected to (AUX pins) to keep it in BL state. So it’s hardware.

@nghianguyen: Did you load 4.0 and update bootloader ? Can you post a picture of your wiring ? Do you have a multimeter handy ?

Hi @philip,

I cannot connect to MP. The Cube is recognized with different COM port than when it boots normal (COM8 instead of COM9) and MP didn’t recognize it. So I have the same thinking with @ThePara as the Cube was kept in bootloader mode (blinking orange forever).

Hi @ThePara,

Thank you for your suggestion!

I have the same thinking as you said that the Cube was kept in bootloader because KISS signal pins are connected to FMU pins directly. I haven’t tried 4.0 Firmware, I used Copter 3.6.12 last time.

I don’t have a picture but I can describe the setup, I used this KISS ESC:

Pin 1,2,3,4 of KISS are wired directly to AUX OUT1,2,3,4 of Cube Black.
TLM and GND are wired to Serial 2 of Cube Black (doesn’t matter because the issue still exists with/without this connection)

4s battery powers KISS ESC, and Mauch Power Module that powers that Cube.

How can I update the bootloader? Is it included when I flash 4.0 firmware via MP as normal process?

Do not update the bootloader unless specifically recommended as you can brick your controller.

Only if Phillip recommends it would I do it.

Hey! @nghianguyen
Is this similar to what you have experienced? I was running dshot too.


Yes my Cube also stuck at boot up, quite similar but mine with ArduCopter 3.6.12 and Cube was blinking orange continuously and no sound from buzzer. How did you solve your problem?

Hey @nghianguyen
My cube was fine after reboot. But it does happen ones in a while randomly. I’m wondering whether it has anything related to io line. Because both of us are using dshot.

Can you please upload a flight log !? Shortest one you have.


My latest log here (I powered the Cube via USB, waited for booting complete, the connected the battery and removed USB cable):

Thank you!

Yeah I have a quite similar situation! Sometimes after I reconnect the battery( power cycle) the Cube did booted up normally! But for about 10 attempts I will have 1,2 times that it boots normally, and most of the time the Cube stucks at booting with orange light flashing.

I wanted a log from @Mallikarjun_SE. I wanted to see his motor output values for Dshot from a succesful flight. Sorry for the confusion.

Could you tell me what ESC and motor you used for your DSHOT setup?