Cube Orange - can't connect, can't install drivers

I have received my Orange Cube this week and installed Mission Planner on a freshly installed windows 8.1 laptop. I could see the Cube in device manager and Mission Planner but could not connect. (I could see one Cube name + port, not two (mavlink&slcan) which you should see in the port list)


I followed the instructions I found in this post
So I uninstalled the drivers in device manager and installed latest driver.msi (created 10/10/2019), but when checking in device manager, “The drivers for this device are not installed. (Code 28)”
I don’t know if this is relevant, but the left orange cube led is constantly on.

I then checked for beta updates in the help section, installed them but still: no drivers and now I don’t even see any Cube port listed in the MP port list anymore.
I uninstalled MP and installed the beta version, and still nothing…
In device manager I do see CubeOrange-BL under “other devices” (still without drivers), but nothing under “ports”

What am I doing wrong and/or what could I do next to fix this issue?
Any help is much appreciated!

Mission Planner is version build 1.3.7284.4576

(PS: is there any way to check if the cube itself is healthy? I’m sure it is, but I’m just slightly starting to get worried)

Your system is still not fully installing the drivers correctly looking at it.

The Cube now no longer comes with firmware installed so you need to install Ardupilot firmware from the firmware page on MP, You need to select Plane 4.0 or the Copter 4.0 Beta , will it let you do it currently ?

Will it actually let you flash it ?

If it won’t you may have to force the correct drivers to install by manually selecting them.

Thanks for your reply! I found this on the setup page in MP, but I cannot do anything to connect since the Cube doesn’t show up in the port list… Version 4.0 didn’t show up on the Firmware tab, but on the “Firmware Manifes…” tab. (Not sure what the difference is)

I have also downloaded the drivers from the Arducopter firmware page (with and without BL, but I think I need the BL version?)
It would be easy to upload from that page in MP, but I can’t do anything since I cannot connect to the Cube in any way…

Could the Zadig app be of any help to “kick things into gear” somehow? (never used it before)

Since I cannot let my computer “see” or connect to the Cube properly, I cannot flash it :frowning:

Do you have a Windows 10 machine available? After significant effort I was able to get a Win7 machine to connect with MP, but could never upload firmware to my Cube Orange.

With the drivers correctly installed, I have two Win10 machines that will connect to the Cube Orange reliably and upload firmware without any problems.

I don’t think everyone agrees with me on this, but save yourself a ton of hassle and give a Win10 machine a try, atleast to get your firmware uploaded.

After the firmware is on the machine, you can use your telemetry modems and Win7/8/10 to connect to your Cube all day. :slight_smile:

1 Like

Thanks for the advice!
I’m on my way to pick up my dad’s laptop to try it in Win10. If this works I’ll invest in a “new” laptop because I really don’t want to lose any more hours (it’s been quite a few…) trying to fix something that really should’ve been fixed in 2 minutes with the right computer.
Keep you posted!
(I’ll be really happy to see an alive Cube instead of this brightly coloured but lifeless little block)

OK, so in Windows 10 it works smoothly: everything installed fine without any problems. I could install, flash, configure, calibrate, …
When I went back to win8, the problems returned. Moral of the story: I won’t even try using win8 anymore… Win10 is the way to go!

Thanks for the help again!

Cool! Glad that worked out. :slight_smile:

Glad you got it sorted.