Cube Orange constantly beeps programming tone after PX4 stable firmware flashed


I just purchased the Cube Orange and trying to get it run using PX4 firmware. After I flash using QGroundControl or command line upload, the unit is constantly beeping the programming sound. I was able to flash successfully the ardupilot plane and sub firmware but not PX4. Any help would be appreciated. Thanks!


Could be because you haven’t configure it yet? Could you try to select at least the airframe after the fw upload?


After I flash the firmware, QGroundControl can’t load the parameters so I can’t configure it at all, not even ability to select airframe. Is there a way to do that outside of QGroundControl?

I think that you can’t configure outside QGC. Can you send an screenshot of the firmware upgrading moment? Is there any kind of error message?

There’s no error message after upgrading the firmware and after it reboots, it beeps this tune ( Screenshot below of the firmware update process:

Hello again!

So strange…
After the upgrade, althought you don’t have parameters, it connects with the QGC?
In case of negative, can you share a screenshot of de COM ports within the Device Administrator window?

After flashing PX4 latest stable firmware, i’m able to reconnect and flash another firmware using QGC. It’s just not able to detect the parameters and has a constant beeping programming tone from the speaker. I have tried now on both windows and mac and having received the same result.

On mac so here’s what’s listed in System Information:

On Windows, here’s Device Manager under Ports:

Looks like there is an error when on the Summary page that pops up after a couple minutes:

Here’s output of command line upload using ‘make cubepilot_cubeorange upload’ command:

Hi again Jacain,

I don’t know what is happening to you.
My las suggestion is to try with a stable GQC version (seems that you are using a daily build).

Good luck mate.

Thanks for the suggestions. I just tried flashing latest stable PX4 firmware on CubeOrange with the QGC stable and daily build versions on windows and mac and still doing the same thing. The weird thing is I also tried on a separate Pixhawk 4 autopilot and it is also beeping the same constant programming tone beep. It seems there’s a step i’m missing if i’m able to replicate this on two different units AND on two different platforms as I haven’t seen this come up as a general problem on the discussion boards or issues.

I’m following the steps:

  • Out of the box, I plug USB cable to the unit
  • Download and open QGroundControl Application
  • Upon first open of application, I have option to select units as well as unit. I left those as default.
  • Click on upper left icon to open vehicle tools
  • Select ‘Vehicle Setup’
  • Select ‘Firmware’
  • Plug in the other end of the USB cable from the unit to the laptop.
  • Select 'PX4 Pro Stable Release v1.12.1
  • Hit OK and the flashing starts.

when you reboot after flashing the firmware and hear the bibibi sound,wait 30 seconds,the sound will change, and then everything will be normal.

The Pixhawk 4 firmware flash worked after using make px4_fmu-v5_default upload and no longer beeping after waiting some time.

However, the Cube Orange is still beeping even after waiting 10 minutes after flashing via make cubepilot_cubeorange_default upload. So the problem still persists unfortunately.

Hi @jacain!

How did you flashed the Cube Orange with the px4_fmu-v5_default firmware? I got the error message about the id of the board (should be id=50, but the cube have id=140) and could not continue with the upload. I’m having the same problem as you guys, with the cube working fine with Ardupilot, but beeping constantly with PX4. Appreciate any help regarding this issue.

I flashed Pixhawk 4 unit with the px4_fmu-v5_default firmware not the Cube Orange. For the Cube Orange I flashed cubepilot_cubeorange firmware and having the same constant beeping issue as you.

1 Like

when you flashed firmware, don’t stay in setup page, back to groundstation page to wait active system

The solution that I got for this was to use the PX4 1.11 stable release. I compiled the cubepilot_cubeorange_default and flashed the board directly with the terminal (not using QGC). The cube stops the beeps, and the QGC connects with it to start the calibration process. Maybe this version will work for you too @jacain

@colorobot i tried your solution and it did not work.

@mathsan did you build the release/1.11 branch and upload that one?


I just tried it with release/1.11 branch and that one did work for cube orange! thanks @mathsan! However there have been a number of fixes and updates since that release so i’m hoping we could find the issue with current release preventing it from working on cube orange. But this is a good starting point. thanks all!

I have the same issue, however I’m new to this and I don’t know how to compile PX4 yet, is there a chance that any of you can send me the 1.11 stable *.px4 firmware file for the cube orange?

@jacain I found that the v1.12.1 also works smoothly on the cube. I used git checkout v1.12.1 to be on the branch of the most stable release of PX4. Maybe this one have the features that you want!

@Serch_c You can find the stable *.px4 files on this link.