Cube Orange crashes after 60 to 90 seconds into a flight

Cube Orange crashes after 60 to 90 seconds into a flight.

• ArduCopter V4.1.3 (2fb939a1)
• Mission Planner 1.3.76
• CubeOrange 00210047 34385111 31373439 with ADS-B Carrier Board
• Here2 GNSS
• RFD900x Radio Modems
• Lynxmotion HQuad500 frame modified for 30mm carbon fiber arms
• HGLRC Zeus 60A 3-6S BLHeli 32 4in1 ESC running ver. 32.8
• Brother Hobby -Tornado T5 3115 Pro 640kv motors
• Master Airscrew MR Series - 12x4.5 Props
• Tattu 6S 9000mAh lipo
• Mauch PL-4-6S BEC, PL-100 Current / Voltage sensor board
• APD PDB360 Power distribution board
• Holybro Micro OSD V2
• Lightware SF11/C laser altimeter
• Flysight Black Mamba 5.8Ghz VTX
• Radiolink R12DS 2.4GHz RX
• RunCam Hybrid 4k
• 3.58kg AUW

I’ve been flying with pretty much this same hardware setup for the last 18 months or so and have moved the build across a couple different frame types. I currently have setup and tested flight modes Stabilize, Alt Hold, PosHold and RTL everything so far has been pretty uneventful.

I have had only a Few bumps along the way, a bit of a learning curve moving from Dji N3 FC’s. I am still struggling with deciphering logs and getting my tune dilled in etc… till now.

I recently upgraded to larger batteries from 6000mAh to 9000mAh and started testing what my new flight times would be yielding when I started to experience the following scenario.

I take off in PosHold and hover at 1-2 meter height and after 1 to 2 minutes the copter just falls straight down to the ground. The last four flights have produced the same identical outcome each time. During that time I have used two different types of esc’s, inspected and rewired my power distribution system and installed a new PBD, re-flashed ESC’s with latest version of Blheli32, tested and calibrated and continue having the same failure.
In the link posted are all related logs, prams, configuration info, video clips and photos.

(Cube Orange Crashes – Google Drive)

The two video clips are about one minute long and on both the crash happens in the last 10 seconds.

I’m stuck, depressed, demoralized. I hope someone can help me please.

Hi Derdude,

I looked at your second flight log, specifically EKF2 Normalised Innovations

NKF4[0].SV should be related to vertical data

In the graph, it’s clear that there’s some discrepancy in the Altimeter data that’s why EKF is rejecting its data for estimation.
Your lighware SF11/C could possibly be at fault here.
But I myself am not sure what SV exactly means but yeah you can easily check using Lightware Studio and maybe check with disabling the lidar altogether.


Edit1 : My whole analysis could be very wrong since the copter falls suddenly so EKF might have rejected the lidar data because there must have been a sudden drop in range reported by the sensor.

Edit2 : Found something interesting in flight01 log

When the copter starts falling, autopilot detects a sudden drop in altitude and fires all the motors to full throttle. So, ESC or motors could be the culprit. And in the video, i heard ESC initialisation tones at the end which also enforces the idea that its the ESC at fault here
Btw im curious, why are you using EKF2 and not EKF3?

1 Like

Loiter mode is much improved over PositionHold. You emergency flight mode will be Stabilise and normal use should probably be AltHold and Loiter.

I had a quick look and also support the theory that the ESCs shut down for some reason.
In BLHELI settings check and change these settings:
Low Voltage Protection OFF
Low RPM Power Protect OFF

Also you could benefit from setting up the BLHELI telemetry to give some extra data for diagnosis and monitoring, plus the RPM data can feed the Harmonic Notch Filter.

Once you’ve achieved some reliable flight we can help with additional tuning. Yours can be a bit better even before running Autotune.
Set these before next flights
And decide if you will use BLHELI telemetry or not.

1 Like

Hello MindProbe,

Thank you for the prompt reply and the helpful suggestions. I followed your suggestion and disabled the lidar. Additionally I disconnected the SF11/C from the carrier board and its power source.

As for your question “why are you using EKF2 and not EKF3?”. I’m not sure really :thinking: so I enabled EKF3 as well.

While waiting for the next flyable day xfacta Shawn replied and per his recommendations I checked my BLHELI settings and found Low Voltage protection OFF and low RPM power protect ON. So I set it to OFF and Set INS_LOGBAT_MASK,7 and INS_HNTCH_ENABLE,1 as well as hooking up ESC telemetry.

I have a total of three flights so far with the above changes made and all have been successful!

Here are the recent logs.

As soon as weather and time permits ill continue test flights and start looking into the lidar unit itself and what issues it might have?:laughing:

Thank you MindProbe and Xfacta for your assistance

1 Like

Set these, you already have some set but I list them for completeness
and do another test flight, mostly just hover in AltHold
This will gather data to confirm if these HNTCH settings are working correctly.

After that you could probably run Autotune (tip: don’t switch out of Autotune mode until after landed)

And I meant to say you can disable EKF2

Hello Shawn,

Thanks so much for your time and assistance. You’ve been a great help!

I made the following changes:


I finally got to test fly it today and everything went well. Here are the latest logs.

It would be great to complete an AUTOTUNE that produces a nice flyable tune. On the previous airframe (which had high vibration issues) I was able complete autotune and successfully save the new settings, but it was pretty much unflyable just way too twitchy.

Much thanks !

Looks good. You should be able to set these to stop logging the HNOTCH data
and then run an Autotune. Switch to Autotune mode once airborne, and once it completes DO NOT switch out of Autotune mode, just “reposition” and land. After disarming wait a few seconds then good to go.

I would set these:

Hello Shawn,

Feeling pretty confident about the progress and direction things seemed to be heading I implemented the following changes.


I decided to make another test flight before tomorrow mornings autotune attempt. A couple of minutes into the flight it just fell from the sky in the exact manner as the previous crashes.

This is the flight log.

I’m starting to feel slightly demoralized :rofl:

It’s going OK right up until here:

All motors get commanded to increase output because altitude cannot be maintained
Motor 3 (Servo 11) briefly loses all thrust and is commanded to absolute maximum, but recovers
Motor 1 (Servo 9) loses all thrust and is constantly commanded to absolute maximum
Other motors are commanded to reduced output to attempt to maintain stability but altitude control is lost, copter has already rolled
During all this voltage rises and current drops - a sure sign there’s no supply getting through the ESCs to motors.

Check or replace the 4in1 ESC, check the motors and all connections, check the battery to PDB connections too. The flight controllers supply (Vcc, 5.0volts) is stable so most likely a connection problem to the ESCs.

Sorry about the taking so long to respond. The last couple of crashes cracked my frame so I had to order some replacement plates. Since everything must be removed to swap out the plates and in light of the issues I’ve yet to resolve I replaced the following items and performed these tasks:
• Installed Lumenier ELITE PRO 60A 2-6S BLHeli_32 4-in-1 ESC.
• Replaced all four Brother Hobby -Tornado T5 3115 Pro 640kv motors.
• Full inspection of all components in the power distribution system.
• Cleaned up all solder pads on PDB, verified all voltages.
• Rewired everything with 12 AWG silicone wire and replaced AS150 connectors.

My test flight resulted in the same identical failure at almost the same exact duration in flight time as previous failures.
All logs, params and associated video etc… are uploaded to the following google drive location.

Thank You

The voltage raised and current dropped while it lost thrust. Therefore the problem shouldn’t be anything shorted.

System tried to raise throttle output to regain altitude.

The ESC was shutdown probably due to temperature protection, as it seems turned off itself somewhere around 90 degree Celsius

Also I notice ESC 2 and 3 are consuming more current than 0 and 4. Not sure if this is measurement error or the copter was imbalance.

Hi ,
I believe this has something to do with the wiring from the power source to the Orange CUBE / Escs . Please check your supply line for any melted wires. The CUBE Orange is well known to shutdown in mid air on some Ardupilot firmware versions although this may be not in your case from the timings .

Check the voltage reading on the MAUCH pl-4-6s BEC (WHILE ENERGIZED )

Another suggestion would be to replicate the same issue by interchanging your motors/ Escs to localize the fault provided you have the capacity to take in another crash !! i would suggest to use a tether to test the drone

Please advise what firmware is the safest bet to eliminate this risk. I had 2 Cubes fall out of the sky. One of them a black, one of them an orange. The black ran great for a while then just flat out went crazy, bunny spiked and fell to its death. The copter with the orange may have failed due the orange not having a high enough voltage set for the signal line; combines with KDE ESCs not being the most compatible for the PIXHAWK architecture. The black failure was long ago, and I am passed it. Now, I am focused on the potential orange issue now. I need to make sure there isn’t something (before fully biting the finger at the ESC) else causing my motor 3 shutdown, and then crash.

Start with supplying a .bin log file and we can potentially see what went wrong. Cubes dont usually lock up and fall out of the sky unless there’s something external that’s failed

Its the file named: 00000011.BIN

The file is too big to upload here. This site have very restrictive size limits.

Cant access that log without logging into facebook
Can you upload it to another filesharing service like dropbox or onedrive please

There’s a 5volt Vcc power brown-out and something crazy going on with the servo voltage too.
Ensure that only one BEC is connected to the servo rail, and if each ESC has a BEC then disconnect all but one supply wire.

There’s other tuning issues we can go over once you’ve got reliable voltages working.

I can’t seem to pull up a graph that matches what you are showing as I may have a buggy Mission Planner. However, you can find a motor stopped spinning (motor 3 I believe) and the copter crashed into a pond. If I could find a way to correlate the time with what you are showing, I could dive deeper. I cant get my timeline or graph to match though.