Cube Orange Firmware

(Robert Gray) #1

I’ve got a Cube-Orange (Device: Hex/ProfiCNC, Version: 5) and I can load the latest apj firmware with GQC (latest build from 2019-08-28 17:30:09 -0700) as well MP (Ver 1.3.68.1 build 1.3.7180.20891). However, I can’t get any of the later July or August fw to work with MP or GQC.

http://firmware.ardupilot.org/Copter/2019-08/2019-08-29-16:08/CubeOrange-heli/arducopter-heli.apj flashes and the orange light stays on after reconnecting the cube to the USB port but I can’t establish a MavLink connection. Com port is reported by MP as “ProfiCNC Cube H7” and baud rate was also tested from 9600 … 115200 to no avail.

Any hint what I’m doing wrong or which fw version to use?

1 Like
#2

What version Mission Planner? Computer is windows 10? What exact firmware?

(Robert Gray) #3

OS: WIndows 10 build 1809, fresh install
MP: 1.3.68.1 build 1.3.7180.20891
GQC: Development HEAD:016f07a1b 2019-08-28 17:30:09 -0700

I tried multiple firmware version, would be likely too long to list. I tried the past 2 weeks of August and first and last week of July build. Latest version I tried was: http://firmware.ardupilot.org/Copter/2019-08/2019-08-29-16:08/CubeOrange-heli/arducopter-heli.apj

(Matt) #4

I just loaded the latest onto an Orange Cube using Mission Planner on Windows 10. Worked flawless.

  • Firmware is located here: http://firmware.us.ardupilot.org/Copter/latest/CubeOrange/. Right click save as on the arducopter.apj file. Use the load custom firmware function in Mission Planner.

  • Mission Planner is the latest version. I also went to help and got the beta updates. Use Load Custom Firmware to select the apj file you downloaded.

(Robert Gray) #5

MP is the latest including all available beta files (1.3.68.1 build 1.3.7180.20891).

I tested the latest Orange Cube .apj (http://firmware.us.ardupilot.org/Copter/latest/CubeOrange/arducopter.apj) file.

After successful flashing it’s still not connecting (disconnected the cube from USB after flashing has successfully completed, closed MP, reconnected Cube to USB and then started MP). I get the com port reported properly on my machine as “COM5 ProfiCNC Cube H7 (COM5)”.

However, when I attempt to connect to the Orange Cube, it enters the 28sec timer count down after a few seconds and then fails at the end of the countdown with the message “No Heartbeat Packets Received”.

PS. Windows 10 reports com port driver as: “Hex Technology Limited”, dated: 10/04/2017, version “1.0.0.1”.

(Robert Gray) #6

Problem solved and everything working!

The issue was with the driver from 2017!

Going to “Device Manager” in Win10 and uninstalling (with removal of the driver) did instantly fix the problem without a reboot even necessary.

Windows and MP now reports two devices once the Orange Cube is plugged in:

  1. “Cube Orange Mavlink (COMx)”
  2. “Cube Orange SLCAN (COMy)”

MP as well as GQC are now working perfectly fine!

I hope this helps the next guy sorting out the driver issue on Windows OS. In this case the problem was that I installed a “stable” MP first and then updated MP with the latest beta and the latest MP driver msi.

I should have downloaded and started with a Beta/latest MP build from the get go as Windows 10 just stuck with the old driver Version 1.0.0.1 and never used the newer driver that installed minutes later.

Or maybe read… reference: https://discuss.cubepilot.org/t/windows-drivers-for-cubes-direct-install/1539

1 Like
#7

Lol! Yep
Glad it’s working now!

(Matt) #8

OH! It was so late last night I forgot. I was able to load the Firmware over USB just fine. But after I loaded the firmware, I couldn’t actually get a mavlink connection to the Cube over USB. It worked fine over UDP from the companion computer, which is what I used for configuration and flight.

I have no doubt mine is old drivers as well. But the cube is no inside the Solo so I no longer have access to the USB port to test it.

1 Like
(Ian ) #9

Try an older version of master from around June time. They have been doing all sorts with the drivers and I have found June/July master builds most stable for the USB connection especially.

Latest master has been doing all sorts with the Orange especially.

(James nagle) #10

For what it’s worth, this fixed the issue I was having connecting Cube Orange to Mission Planner as well…

(Rich) #11

Thanks Matt. I was finally able to install firmware with your suggestion. Still can’t connect to MP via USB with latest drivers - no heart beat error. Running Win7 and don’t have access to a Win10 machine at the moment to test.

(Rich) #12

My second Cube Orange exhibits exactly the same behavior. Both cubes were received yesterday from ProfiCNC. Using @Pedals2Paddles directions I am able to install the latest firmware, but can’t connect with MP or QGC. For fun, also tried the USB dongle and powering the Cubes in addition to the USB port - no joy.

MP has been uninstalled and reinstalled twice. Tried both the Current and Beta versions of MP. Removed and reinstalled the latest drivers several times. Going to pick up a Windows 10 lappy this afternoon and see if that makes a difference.

1 Like
(Rich) #13

Windows 10 was a no-go. Win10 1709, Current version of MP and Beta both failed. Updated with latest drivers. After the driver update It just stalled on “Mavlink Connecting”. Reboot, etc.

The good news… connecting with a telemetry radio worked like a champ. Testing continues.

#14

@wn0x

  1. Ctrl-F in MP
  2. Select the Clean drivers option i think on the right side of buttons.
  3. download the current direct install drivers floating around on this forum.
  4. install the drivers and that solved all my issues with win 10 current beta mp no issues installing latest date firmware
1 Like
#15

Check your device manager and look at the ports, what comes up when plugged in?

(Rich) #16

Originally: ProfiCNC CUBE H7 (COM5)

After running “driver clean” it reads as follows:

Cube Orange Mavlink (COM7)
Cube Orange SLCAN (COM6)

A shout out to @Matt.C as running driver clean, uninstalling the drivers and reinstalling them solved the problem on Win10. Evidently driver clean does not run (or appear to run) on Win7. On Win10 I had to click through numerous Windows security alerts for PnPUtil.exe. On Win7 - no response when clicked.

(Rich) #17

Windows 7 is now working, however - truly odd behavior.

Steps:

  1. Delete ProfiCNC CUBE H7 from device manager while the Cube Orange is connected with the option to delete the driver, then disconnect the Cube Orange.
  2. Uninstall and reinstall the latest drivers.
  3. Reconnect the Cube Orange - two entries will show up in “Other Devices” named CubeOrange-BL. The top entry will change to CubeOrange. You will see the message from windows notifying you that it is installing device drivers.
  4. CubeOrange-BL will move to the Ports section and be named Cube Orange Mavlink (COMxx)
  5. If the “CubeOrange-BL” in Other Devices" does not move to Ports after a few moments, right click on it, go into properties, click on the driver button and - do absolutely nothing else - for some unknown reason CubeOrange moves to Ports and is named Cube Orange SLCAN (COMxx)

I have now duplicated this behavior 5 times, at great risk to my sanity.

1 Like