Cube Orange First time uploading firmware issues

Im sure this has already been answered but i’m not finding it. I’m trying to upload firmware for the first time to my cube orange. My windows 7 computer recognizes that its there in the device manager as well as MP COM select. It asks me if this is a Linux board… I select No. It then comes up with a COM Error, Unable to Connect. I’ve been reading some places that I have to put the unit into DFU mode. How do I do this on a Cube Orange or do I even have too? I’ve downloaded the STM232 Cube Programmer but don’t know how to use it. If there is a thread on this please direct me to it. Sorry to be the new guy here. Please Help!

Officially windows 7 is not supported and that’s why your having issues.

With Windows 10 you must download the latest Mission planner and Drivers and then install that way.

You can try the following but this may not work as there is no firmware onboard already

Cube Orange & Yellow - Windows 7

There are known issues installing the Cube Orange and Cube Yellow with Windows 7. Its advised you use Windowns 10 or later however Windows 7 can be made to work in some circumstances by manually deleting the driver files and installing the latest driver file and forcing Windows to install the correct driver manually.

  1. Delete ProfiCNC CUBE H7/F7 from device manager while the Cube is still connected, then disconnect the Cube from USB.

  2. Uninstall and reinstall the latest Cube drivers as linked above.

  3. Reconnect the Cube Orange/Yellow and two devices will show up in “Other Devices” called CubeOrange-BL.

  4. The top entry will change to CubeOrange and you should see the message from windows notifying you that it is installing device drivers.

  5. CubeOrange-BL will move to the Ports section and be named Cube Orange Mavlink (COMx)

  6. If the “CubeOrange-BL” in Other Devices" does not move to Ports after a few moments, right click, go into properties, click on the driver button and wait, it should then move to Ports and is named Cube Orange SLCAN (COMx).

Thank you for the reply. I’m normally a Mac person and keep the windows laptop around for things like this. The two Com Links (Cube Orange Mav Link) and (Cube Orange SLCAN) do already show up. But I haven’t followed the procedure you’ve written yet so I will give that a try. Or I will have to buy a copy of Windows 10.

I’ve given it a try. I couldn’t find any device listed ProfiCNC CUBE H7/F7. But it does list the following:

Cube Composite Device
Cube Orange Mavlink (COM6)
Cube Orange SLCAN (COM7)

So the computer does see it. But Mission Planner is still having a problem with it. It fails to connect with the board when installing the firmware. So the problem is windows 7 and Buying windows 10 is the answer to this? I just want to check before I spend more money.

Is there a way to force load the cube? I’m trying to understand the STM232 programmer as I read in the instruction at ardupilot on setting up a brand new cube. As I understand it, when the firmware is loaded the first time I shouldn’t have this problem even with windows 7. Has anyone had any success in using windows 7 for first time cube setup?

Try giving QGC a go on the Orange and see if it loads it. Win 7 has had some driver issues but if your seeing both ports it should be fine now.

Will Do

Hey! If it’s brand new Cube, there won’t be any firmware on it and it won’t connect. Select the right COM port and install firmware. If mission planner doesn’t recognise the right firmware for you, download .apj file from this link and use custom firmware button on Mission planner to flash it.
https://firmware.ardupilot.org/Copter/stable/CubeOrange/
This is for stable copter.
Share a video if this doesn’t work.

I will give that a try too


This is what I’m getting from QGC

Try mission planner with right COM port and custom firmware button.

Im making a video of it now

While I wait for my 2 minute video to process, heres what happens.

I plug the Cube Orange into the USB.
The device manager shows all devices all working properly

Cube Composite Device
Cube Orange Mavlink (COM6)
Cube Orange SLCAN (COM7)

I then launch Mission Planner
I select Mavlink Com 6
I then load the recommended custom firmware for the Cube Orange.
It asks me to Unplug the board and plug it back in.
I then hear the Com Link sound several times.
The satus bar shows “Scanning Comports”
After several moments the status bar reads "ERROR: no response from the board
The device manager shows an error as well. "CubeOrange-BL …This device cannot start.

Have you tried forcing bootloader ?

Not yet. I’ve never done that before. I will give it a try.

I just gave it a try. You hear the Com link kick on and off. Then the status bar in MP times out. Checking the Device Manager it says: ! Cube Orange Bootloader (COM9)…This device cannot start

Try installing the beta mission planner, go to help screen and get the beta updates and reboot and try it again.

The status bar in MP seems to hang on “Scanning Components” and then the program locks up. But the Device Manager is still showing everything is working properly. In Force Boot Loader mode it causes the same error. Cube Orange Bootloader (COM 9)…This device cannot start. But the USB device and Cube Orange Mavlink (COM 6) always seem to work.

install lastest beta Mission planner. Can you make a video. It will be easy to understand what’s happening. From visual to usb sounds.

Actually I took the windows 10 route. I downloaded it, installed it and now there is no problems. Mission Planner connects Flawlessly now. Thank you very much for the help and suggestions from both of you on this thread.

2 Likes

Nice! :grin: