Cube Orange Multirotor performing weirdly

Hello,

We are using this cube orange for quite some time now and have used it in various frames of similar sizes for testing purposes and have performed well.

However, recently, while flying for one such setup, we came across a weird issue of yawing on the right automatically, delay in commanding, altitude changes, etc.

During the maiden flight with the same board, and same quad, the performance was almost proper and required a little physical balance change from our side.

Our flying mode was Loiter and this sort of issue I have never observed while flying in Loiter mode.

Also want to understand that, how close to the center is OK for the placement of FCB and GPS. In this one, we have had FCB and GPS 35mm (approx.) in the X direction from the CG point.
So in the maiden flight, the same was changed and made to 35mm in IMU offset.

On the next flight with issues, we tried both things, without offset and with offset, and the performance remained the same.
Additionally, out of the 3 test flights, in the last one, after landing, before the motor turns off, it automatically flipped on the back.

I would like to know the reason behind the issue.
And to know the offset requirements for FCB and GPS. Also, the need for Z value in GPS offset also requires an understanding. Because GPS is always at a certain height.

Logs link - Bin Logs – Google Drive

Thank you for your time and help.

Upgrade to latest stable firmware - there’s at least one important fix related to the Cube Orange, plus quite a lot of other fixes.

Definitely set these for safety
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2 or 3
FENCE_ENABLE,1

With the Fence setting you will not be able to arm in any mode until there is a good GPS 3D Fix and Home can be set. It takes time (the first time) but you get used to it. I believe this setting is essential in your case, since there seems to be so much trouble with the GPS position wandering and the update rate.

You can see on the map, the IMU calculated position and GPS position rarely align. Most often this is caused by vibrations, but your vibration levels are very good. The cause seems to be a lot of variation with the GPS update rate (GPA.Delta) and position. This is usually a sign the GNSS unit is getting overwhelmed by the number of constellations.
I believe this poor wandering position is the reason for your tip-over and probably other troubles, since the copter is trying to reposition unnecessarily and even while touching the ground during landing.

Try these values to see what works best:
GPS_GNSS_MODE,5 or 65
You are looking for good reliable HDOP. The LED indicator will go green when once Home has been set.
And set this to allow time for the CAN GPS unit to boot up before the flight controller
BRD_BOOT_DELAY,3000

image

These will aid tuning and are very safe
ATC_THR_MIX_MAN,0.5
PSC_ACCZ_I,0.52
PSC_ACCZ_P,0.26
INS_ACCEL_FILTER,10
INS_HNTCH_ENABLE,1 ← set this then refresh to see more params
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.14
INS_HNTCH_FREQ,90
INS_HNTCH_BW,45
INS_HNTCH_FM_RAT,0.7
INS_LOG_BAT_MASK,1
INS_LOG_BAT_OPT,4
There will be more adjustments required after the next flights.

I think you can set these to cut back on some unnecessary logging:
LOG_DISARMED,0
LOG_REPLAY,0

For the next test flights takeoff and land in ALTHold or Stabilise mode until you are sure the GPS position issue is solved.
Just hover for a while, and do gentle pitch and roll manoeuvres. Try testing yaw too of course.
No need for aerobatics or running missions.
Let’s see that .bin log file.

The placement of the flight controller and GNSS unit doesnt have to be compensated on a small copter. According to the log I’d estimate your props to be 10inches, so there’s not much chance of you being able to place the FC or GNSS far enough from centre of gravity to make any real difference.

Hello,

I have trying to update the Cube first. However, I am not able to upgrade it to the latest version. The cube connects and works easily. However, for upgradation, it shows an error.

Any help in that part?

Need more info - what errors?
Try disconnecting telemetry radios or any other accessories so USB is not powering more than it has to.

Mission planner failed to detect port to upload to…

Flash plane firmware and then switch to latest firmware. If doesn’t work flash Default px4 firmware. Download it externally and then flash it through mission planner.
If doesn’t work email me govind.sikhwal89@gmail.com

I do not know how to load default PX4.
Apart from that, I tried upgrading it to plane. Same result, not able to detect the port to upload to.

Tried with Mission planner ALL OPTIONS to load the firmware. It downloads the firmware, after disconnecting and conenction, says “Error, no response from the board”

Also tried with downloading the firmware and uploading under upload custom firmware. But shows a similar error.

For updating firmware into the Orange CUBE, you need to have the correct drivers to be installed in your PC I have both tested Px4 stack on both fixed wing and multirotor.

Thanks for the hint.
If can help me with the name of the driver, I can try downloading it for my PC.

I have windows 7 and 10 options

You dont need to install the drivers if you are using the same laptop or desktop you were using previously. I think i can help you, tell me when you connect the cube to your desktop does the orange light goes after some time? If it does then this there is nothing to worry about you just need to follow some steps.

Please follow this link
https://discuss.cubepilot.org/t/re-orange-cube-herelink-px4-current-version-is-1-11-3/7823

Here is a link to the latest MissionPlanner driver.msi
https://firmware.ardupilot.org/Tools/MissionPlanner/driver.msi

Actually, I am already using this. Everything is upgraded to the latest version.

Attaching the image for reference.
Please check and let me know if you find anything not updated.

While taking screenshots for this response, I did not understand one thing. If you see, the Control panel version of Mission planner is 1.3.77. Whereas, when I open my Mission Planner, it says 1.3.79. Is this normal? Kindly check the below image for reference.

cap2

Thanks

Okay.

Yes. it goes off.
Thanks.

Actually, it connects with MP so the board is definitely fine. But for updates, it needs some process.

Sorry.
I think, this link no longer exists.

Still i would recommend to flash a different firmware and hopefully all the errors or issues would go away

I tried different firmware for the different vehicle types. The error comes out to be the same, Failed to detect the port to upload to.

Did you get your drivers installed correctly.

The driver.msi also includes drivercleaner.exe which must be run as admin
Find that file and right-click, run as admin

@Harish… can you upload a screenshot of the COM ports under device manager detected by Windows here…