Cube SBUSo settings - solved

I am trying to controll gimbl Pixy F (new one from gremsy) via SBUS on pixhawk.
I connected Pixhawk 2.1 SBUSo connector tu pixy SBUS input.
I did enable SBUS_out = 1 on pixhawk.
I thought it automaticly transfer my PPM in (from herelink) to SBUSo. All channels as they arrive from herelink. Obviously i am wrong because i cannot read any reasonable channel on my gimbal app.
Do i have to somehow map sbuso channels to my herelink channels?
I hope my connection is correct. I guess pins on standard carrier board from cube to main out are in this order 1. GND 2. 5V 3. Sbus

1 Like

You need to set up the ins and outs with ardupilot same as any output

Can you be please more specific what parameters to change?
I changed sbus out to 1.
I want to use my channel 8 to be sent from pixhawk to sbuso. How?
I cannot find any parameters called RCIN/ RC9IN the same with name out.

Thank you very much i managed to get it working.


Hey, can you please explain how you did it? Trying to do same thing for my Gremsy T1 V1 that doesn’t support direct Herelink connection

hello. it was some time ago. The connection was easy. from herelink air unit to cube, and from cube sbus o connector to pixy gimbal. I dont remember if i had to change some arducopter settings, but here are my settings if you want to take a look. (5.3 KB)
unfortunately i cannot find gremsy settings i did, but i remember it wasnt difficult.