Downloading Parameters Consistently Failing

(rge99) #1

On startup the Downloading Parameters does not ever complete. In the logs, it shows a continuous retry. It is connecting to the FC but the parameters are not downloading. When connecting directly to QGroundControl on the PC, the parameters download with no issue. It used to work but has stopped. Any help would be greatly appreciated.

Additionally, the MavLink Status shows a very high loss rate (96%) - Total sent: 196850, Received: 8192

(rge99) #2

The telemetry connection works fine as I get all the prearm checks and other information. Just the parameter download is not working.

Just noticed the video is not working either anymore.

Any ideas?

(rge99) #3

More diagnostics - after enabling hotspot which turned off wifi, the video started working again but still no parameter download. The transmitter does not have either LED lit. Is this normal?

#4

What firmware is on the Autopilot connected to the HereLink? Is it setup correctly?

(rge99) #5

I spent the better part of the day troubleshooting and finally did a complete factory reset and reload and it started working!. I had noticed over the past couple of days, it had become less and less reliable to the point where after restart, the physical throttle did not work until I rebooted. It’s working now! Thanks…

1 Like
#6

@sidbh

(rge99) #7

It’s back again - the remote is not downloading parameters. It is communicating with the receiver/fc as, it recognizes when I disconnect and reconnect telemetry. I cannot spend another day tinkering to figure this out. Hopefully, someone can suggest a better diagnostics other than continuous trial and error. Parameters download fine over QGC and MP while the remote hangs.

(rge99) #8

working again - just through power cycling the receiver several times

#9

Do you have mission planner or QGC connected at the same time as HereLink by any chance?
Is any other device on your same network?

#10

Post some logs please

(rge99) #11

My typical setup is build & load firmware and run mavproxy outputting on port 14550. Sometime, I will run MP when troubleshooting. I ran QGC to verify it could download the parameters while the HereLink could not.

1 Like
(Don Gagne) #12

With that high of a loss rate I would say the telemetry is not working fine. It may seem to be working since most telemetry is streamed repeatedly. But at high loss rates communication from GCS->Vehicle will be flaky. Hence protocols like parameter download or mission upload/download protocols will start to fail. You’ll also start to have problems commanding the vehicle to do things like say RTL from the GCS. None of which is a good thing. In general if you have really high mavlink loss rates you shouldn’t fly.

(rge99) #13

The logs from QGC or the FC?

Not sure how to get logs off of the remote.

The console log starts out when the receiver is connected with…
Request to refresh all parameters for component ID: MAV_COMP_ID_ALL

TypeError: Cannot read property ‘connected’ of null
TypeError: Cannot read property ‘active’ of null
TypeError: Cannot read property ‘numSattelites’ of null
Retrying initial parameter request list
Request to refresh all parameters for component ID: MAV_COMP_ID_ALL
“STAT_RUNTIME” count: 1002 index: 65535 mavType: 6 value: qVariant(int, 0)
Disregarding unrequested param prior to initial list response “STAT_RUNTIME”
Retrying initial parameter request list

Actually just figure out how to download the QGC log - here (renamed .txt to tlog to be able to upload)Log1.tlog (267.1 KB)

#14

Im having the same symptoms - Herelink QGroundControl not able to download parameters from the cube via its RC link. High loss rate observed from MAVLink status: 50-65% message loss mostly. When connected via USB to cube - loss rate is 0% and parameter download works as intended. My problems started when my previous cube black died and I replaced it with new black cube - and ardupilot fw version changed from 3.9.8 to 3.9.11.

#15

Update: in my case it turned out to be faulty Telem1 port on carrier. Switched over to Telem2 and parameter download started to work. Mavlink loss rate still goes between 40-63% - is it normal with herelink radio?

1 Like