GPS here 3+ not showing up on CAN inspector

I recently got a GPS here 3+ and a Cubepilot Orange+. I wanted to update the GPS here 3+ firmware to the most recent one v1.12 (originally it was v1.3) as I’m interested in using the here 3+ as an external IMU. By default, v1.12 doesn’t publish the IMU data, therefore I changed the source code and compiled the .bin file again. I was able to successfully get the IMU data with the GPS here 3+, and this worked with no issues. The change was to make equal to 1 the following parameter: define AP_INERTIALSENSOR_ENABLED 1 on the here 3+ hwdef.dat

I’m looking to get the IMU data from the GPS here 3+. So, I tried to update the GPS firmware via Mission Planner through Mavlink CAN1 (same way as I did it multiple times before). However, during this process Mission Planner got stuck during the updating process on the “progress window”. After this, I’m not able to see the GPS here 3+ on the CANBUS. Although, on the inspector it is possible to see the information from the GPS Here 3+. The compass (in the calibration window) and GPS (in MP messages) are being recognized by ardupilot. I’m not able to update the firmware again as the GPS here 3+ doesn’t show up when I scan the CANBUS. I attached some screenshots. Sometimes after a while, it shows up on MP but it is not possible to update the firmware anymore.

Do you know if there is another way to re-upload the firmware? Or what can I do to make the device show up again on MP?

I’d appreciate any suggestions.

@robodev Can you try DroneCAN GUI — Plane documentation . You may need to bring down the IMU data update rate, it might be choking the bus.

Thanks for your reply! I tried to connect to the GPS via DRONECAN GUI without success. I attached a screenshot where the GPS doesn’t show up. It appears intermittently.


I tried via MP and somehow, I managed to modify this parameter to zero: AP_INERTIALSENSOR_ENABLED = 0. Note that on Mission Planner the GPS also appears intermittently which doesn’t provide enough time for a firmware update. I attached a picture of the new topics where the IMU was disabled. Even after this modification the GPS keeps showing up momentarily and I haven’t been able to update another firmware. However, the GPS and compass seems to be working fine on the Ardupilot side.
Any suggestions to do a factory reset on the GPS? Is there any button inside the GPS? I don’t mind trying to open it.

What version of Ardupilot are you running on the Cube. Can you load latest Dev Ardupilot from here: ArduPilot firmware : /Plane/latest/CubeOrange . On Cube, set LOGGING_DISARMED to 1. Share the log, I want to see Can stats and see what is failing.

Thanks for your reply. I’m running Ardupilot 4.4.3. Here is the log file:

6 12-31-1969 7-00-00 PM.bin

@robodev have you tried connecting over MAVLink-CAN1. You can also connect with DroneCAN GUI Tool over MAVLink port. Check if that helps. From the logs, there doesn’t seem to be any clear issue at the receiving end on Ardupilot. Even GPS messages are being received at 5Hz as visible on GPS Delta. So I am wondering if the issue lies with the SLCAN itself. Another thing to try would be to update to the latest master firmware on the cube as well.

Hey, I just wanted to provide an update on this topic:

  1. I carried out a flight using the same GPS and tested the RTL feature successfully. This shows that the GPS is still usable for flight (log file attached). Although, the GPS still doesn’t properly show up in Mission Planner (image attached). This was running ArduPilot 4.5.1

  2. I played around with the DroneCAN-GUI tool. I’m attaching two screenshots. One with a GPS that’s fully working and showing up in Mission Planner. And one with the GPS that has the issue. Based on that, there might be a difference in the amount of packages that are being sent via CANBUS. I wonder if that’s what is causing the issue or not.

Log file