Here 2 Bricked on firmware update

I followed the instructions on this page.

I was using ArduPlane4.0.1 rather than the ArduCopter 4.0.0-dev when I flashed the bootloader. (As you can see in the screenshot below.)

I updated the bootloader, no issues, waited for sold green lights, rebooted (for sure had solid green lights + waited another 30 seconds before rebooting), reconnected. But now when I click on SLCan Mode CAN 1 on Mission Planner nothing happens, no errors, I can’t finish updating the firmware. Sold green lights still. I took a screenshot of the UAVCAN firmware details right before I flashed the bootloader.

I’ve tried swapping to the ArduCopter 4.0.0-dev but still no luck. Any ideas?

1 Like

Are you using the Beta MP I can’t remember the number of the top of my head looking right now to compared yours to

What can port are you in ? Is is the middle on on the standard carrier ?

I did have this but just kept playing and it kicked in the end. If I recall I may have left it all on and connected for a while before it kicked in.

Something else too try is downloading a June or July version of copter from a daily build and try it with that.

1 Like

Try connecting the battery to the pixhawk. because of the long usb cables and the cable to gps it is possible to bigger voltage drop and therefore probably did not work since that was the case with me


I got it working! Thanks.
I’m not 100% what I did to get it working. I flashed the beta arducopter like the instructions said. I powered it using an external power supply like Jernej_Fajdiga suggested. I tried waiting for a while after booting before doing anything. I also installed the UAVCAN tool I was going to use that for debugging it but right after I installed it everything started working. I’m wondering if it installed a driver or did something to my Windows OS that fixed it. Might have just been a coincidence too. Thanks, hope this helps anyone else that runs into this.