Here 2 over CAN - No Compass and GPS

I have a cube orange with a here 2 gps connected to the CAN 1 port (the correct labeled one). All parameters are set as described. Firmware is 4.0.3 on the cube and 1.3.75886496 on the here 2 gps.

My setup was already flying with this configuration. I had sometimes problems with a gps and compass pre-arm message before. Until now those messages went away after a few restarts.

But now it’s not working anymore. In mission planner i can see that everything is connected. I even get a fix. But magnetometer 2 is not showing any values. Connecting via SLCAN tells me the here 2 is operational and the health is OK.

I tried to set BRD_BOOT_DELAY to 5 seconds. But that did not help. And i already ordered a here 3 gps in case it’s a faulty GPS module.

Here is a link to the bin file and the DVR of my last successfull flight:

and some pictures:

normally Mag2 Field is showing me it’s values, but now not anymore

i have disabled the onboad compass, because the cube is too close to my power cables

This is what HW ID is showing me:

here are the messages shown repeatedly

thats the hardware setup:

i fly with redundant cube orange flightcontrollers, the GPS is connected to my primary fc on the CAN1 port

Is it possible that i have some parameters setup wrong?

Looks like compass is not detected.

1 Like

I looked at this parameter. It was set to 32. I changed it to 0 and made a restart:

still the same

so i changed it back to 32.

I may have found the solution:

I updated to firmware 4.0.4 BETA. Now the compass is recognized again.

And i realized that the layout of the compass menu has changed.

Rather strange that it worked for some time with 4.0.3 and 4.0.2.

I just don’t feel comfortable to use BETA releases. Maybe someone can explain this error to me.

I will test it in the field tomorrow. Hope everything works.

Yes, 4.0.4 BETA solved my problem

1 Like