HERE 2 settings as I2C in Mission Planner

Hi, there
what are the right settings and setup in mission planner for the Here 2 antenna?
I have connected with the I2C cable and not as UAV CAN.
I´ve maded this settings, are they OK so?

GPS_TYPE as 1: Auto or 2: uBlox?

Is the priority order OK here?

Thanks in advance for your answers.

Leave GPS on auto.

Looks correct of the Mag but what is the CAN device it’s detecting ?

Also note you have the internal SPI mag set as external. This needs to be unticked.

I’m also getting same kind of issue here2 connected on CAN no more I2C. But it detect internal compass as external and it can’t uncheck from external compass.

@Michael_Oborne this a bug ?

You can uncheck it. This shouldn’t happen since it’s on SPI.

I was tried to uncheck the LSM303D compass from external but its not happening.

i´ve tried but it´s not possible to uncheck this, i don´t know why…

I have configured in full parameter list page and priority orders also I have setted.but couldn’t uncheck via compass calibration Page

Use COMPASS_TYPEMASK to disable it.
Try setting COMPASS_EXTERNn==0 in full param list.

Yes that’s what I done using compass_externaln==0 . thank you.workong fine .