Here 3 Firmware & RTK Issue

I’m experiencing RTK issue with Here 3 GPS with ArduCopter 4.0.7

In the u-center with CAN passthrough,
I found UBLX MON VER measage reports as SPG 3.0.1 Firmware before and after the successful update(from u-center firmware update tool) as according to Here 3 manual while ublox says M8P chip should report HPG firmware.

And also unable to get Here 3 into RTK float or fix only get 3D fix while another GPS module using M8P chip can enter into RTK float status.

I need help on this issue.

P.S - I have uploaded this ublox firmware - https://www.u-blox.com/en/ubx-viewer/view/UBX_M8_305_HPG_143_ROVER.74d7454b395e2fdf680d864f40b9dbed.bin?url=https%3A%2F%2Fwww.u-blox.com%2Fsites%2Fdefault%2Ffiles%2FUBX_M8_305_HPG_143_ROVER.74d7454b395e2fdf680d864f40b9dbed.bin

Can you show the u-center > view > message view > MON > VER screen?

Did you turn off the passthru mode after updating?

HERE 3 Passthorugh U-center- MON - VER after HPG firmware update for M8P

I did turn off passthorugh or ArduPilot would report No GPS rather than 3D Fix

How many satellites do you see on the RTK screen when surveying?
https://docs.cubepilot.org/user-guides/here-3/here-3-manual#base-module-setting-using-mission-planner

Do you see the “SurveyIn Acc” converging over time?

Hello
Where can I download the program you’re using?

That’s u-Center from uBlox. You can get it from their website: https://www.u-blox.com/en/product/u-center

I tested RTK with NTRIP and I have another M8P that can enter RTK float or fix
while HERE3 modules can’t

What RTK base are you connecting to your GCS? Is it capable to output NMEA data?

I used NTRIP in mission planner, network provides RTCM 3.1 which has been worked and working for UBlox M8P & F9P GNSS chip other than HERE 3.

Have you tried to update the Here3 firmware again? Not the ublox firmware, but the Here3 firmware.

It should work as long as the ntrip address is correct.