Here 3 firmware update fials

Hi, today I tried to follow this guide for updating the firmware on a Here3 RTK module (Here 3 Manual - CubePilot) only to end up loosing the very expensive piece of equipment…

I am using Pixhawk 4 flashed with the latest stable version of ArduCopter (4.0.7) and the latest beta version of mission planner ( build 1.3.7846.10795).

The flashing operation starts and gets past the download stage but after that the flash bar never loads completely and the process seems to crash. After attempting this, firmware version on the module reads “0.0.0” and the GPS no longer works at all.

Would really appreciate some help recovering the bit of kit.


Does it still show up in SLCAN?

It does, yes. It allows me to repeat the flashing but keeps failing.

Can you try if it works on another CAN port?

Hi Alvin, I have tried this. It doesn’t work either.

I have a similar issue with the same setup. For me, it does not complete the download step, the update window with “125 fw.bin” crashes after loading 20%. I have tried flashing with another Pixhawk 4 and a Cube Orange and it keeps failing the same way.

I can try updating the firmware offline. @Alvin can you please share the firmware file for the same.

Thanks in advance!

Can you show a screenshot of the SLCAN page?

Here it is.

I’m having this exact problem, but now I can’t get Mission Planner to connect via UVACAN as it is stuck in this Maintenance Mode after the firmware upgrade.

I’ve spent hours online trying to find a solution but nothing, does anyone know how to get this GPS module out of the maintenance mode? via tcp port or something?


Can you try to update it again?
If it still not working, try with CAN2 and SLCAN2.
Also, what version of Ardupilot are you using?

I purchased the here3 6 months ago and had the same issue, would never update. critical error was I i ever got, no help what so ever from this forum and definitely no help from the here3 manufacture. after 3-4 weeks I smashed it with a hammer so I could not return to it and waiste any more time in it

please try updating your version of arducopter, possibly beta copter. as there could be a can issue preventing the update