Here 3+ gps connection issue

Hello everyone,
I am facing some issues with my Here 3+ GPS devices and wanted to know if anyone can help me. Actually, I have recently purchased 2 Here 3+ devices and I’m facing some issues with them:

  1. I purchased this Here 3+ GPS a few months ago, and it was working great initially. However, due to a crash, I had to change the CAN cable. I tried to update the firmware as per the instructions on the Cubepilot forum, but after that, Mission Planner cannot detect the GPS. Every time I try to connect, it shows “White solid lights.” I have checked the forum, and they mentioned that I need to update the GPS again through SCLAN mode, but I am unable to connect to that mode or the GPS.

  2. After the previous issue, I purchased a new Here 3+ GPS, which is detected in Mission Planner, and I can see it in compass calibration. However, it is not connecting to satellites. I have even tried it on an open ground, but the satellite count remains at 0.

Please let me know if someone can help me with a solution for any of the above issues.

Did you change GPS_TYPE: 9, If you see compass I assume you changed the parameters for Can driver and protocol.

Hi @doug , I have changed GPS_type to 9 and all paraneters as mentioned in cubepilot documentation.

I’m having the same issue. Did you get it fixed?