Here 3 GPS - No fix

Hello all,

I am trying to use the Here3 GPS and HEX Cube Orange with Ardupilot (Copter 4.3.1 Official) firmware for my drone but so far I am not getting any signals or 3d Fix from the GPS. I have been using Mission Planner (V1.3.79) as the ground station software. It would be great if I could get assistance in solving the GPS 3D fix issue.

Below are some of the steps I tried until now to get the 3D fix.

  • modified the parameters in Mission Planner (as instructed in the official website)
  • updated Mission Planner and the Here3 GPS (as instructed in the official website)
  • changed the CAN node ID
  • tried to connect to u-center (doesn’t show any satellites though)
  • checked in both inside my house (closed space) and outside (open space)

Please let me know any additional information I need to provide too.

Hi
Did you get 3d fix before on this GPS unit ?
Can you please share your MP HUD ?
What is the LED indication?
Did you try with another CAN port?
Do you have another GPS or FC ?
Can you swap GPS and FC and see if this issue happened again on that GPS or FC?