Here 3 stopped working when updating firmware


I wanted to use the Here 3 GPS module with PX4, in order to do so I followed the instructions here to manually assign a CAN node ID:
However, this did not seem to work as the node ID was different once I turned the autopilot on and off again (still in ArduPilot).

It occurred to me that it might be a firmware issue and so I tried to update the firmware of the module. This did not seem to work, the software version didn’t show up. After trying again, the module got stuck in maintenance mode with critical health while the blue lights continued to flash. Now I cannot even see the GPS in the UAVCAN tab and the blue lights are still flashing, it seems like the GPS has been rendered useless. What can I do?

Habe you tried flashing in MP again ?

Yes, I have. The issue is that the device doesn’t show up in the UAVCAN tab, so I cannot do the flashing

@Daniel_Nieto any luck finding a fix? I’m having this same problem and I can’t get my Here 3 GPS out of maintenance mode.

make sure you are running a very new arducopter. older versions sometime have flashing issues.

Hi Daniel, did you happen to fix this issue?
I am having the exact same problem.


Daniel, I am also having the same issue. Any resolutions?