Here2 GPS Clear LED/No GPS Fix

Hello,

I am currently having issues with my Here2 GPS connected to GPS1 with the switch set to I2C.

Only one LED is on, its solid, clear (looks blue in the picture, unless I’m mistaken) and its bright. No colors.
All three RED LED are blinking, and the failsafe switch works.

On initial powering on the receiver, only the clear LED turns on. The rest of the other LED are not on.

Mission Planner is showing ‘NO FIX’, so I’m assuming the GPS is communicating just fine with the Cube Black.

I have tried configuring it with CAN, and I am getting the same result. I just want to confirm if I have a dead GPS, because it was working fine couple months ago.

Please let me know if you guys need further information.

Thanks again!

Can you try to update it via UAVCAN?

Hi Alvin,

Thank you for the response.

I think that was going to be the next step. Unfortunately I do not have the CAN cable, and there are hardly any online stores that carries it. I’m kind of stuck at this point.

You can’t use the I2C cable for CAN.
You can try serial passthrough via the Cube, to connect your Here2 directly to u-center. So that you can direct access to the u-blox chip, to see if it is receiving satellite signals.
But this only verify the GPS.

You may contact your local reseller and ask for RMA.