Here2 not working with CAN - Solved

Initially using a Cube Black and a Here 2 I was able to connect with the latest Mission Planner and Master Copter and see and update the Here2 firmware using the Internet Method. This I just figured out after briefly watching MadRc’s Youtube video.

Then I had the (misfortune!) to read the official doc here: (this seems to be outdated BTW)

I followed those steps and manually updated to the bootloader and firmware linked. Now I cannot see my Here2 in the UAVCAN SLCAN viewer in Mission Planner. I have tried many times. I think I may have flashed older firmware. I am only using the latest MP and Master Ardupilot.

In any event, what am I to do now? This lights are just solid green. No matter what I do I can now no longer see the device in the SLCAN viewer.

I have a second Here2 that I have never been able to even see on SLCAN in Mission Planner. That just has alternate flashing white LEDS. Both of these were basically new out of the box. I even waited for the firmware to stabilize before using these.

Please can I get some help. I have read through the threads and I see nothing that can help me.

We need a way to flash these other than using SLCAN so we can get out of this situation. I have two NIB Here2 units that are seemingly useless as CAN devices. Not happy.

@philip I have two NIB Here2 units from ReadymadeRC that are not working. They were shipped in i2c mode so they are an earlier production batch. I am not a noob at this stuff generally. The first simply never worked and was never visible through SLCAN on Mission Planner (latest as of a few days ago). The second was immediately visible when I activated the Can1 driver in MP and connected to the CAN 2 port with the switch in the CAN position – this does show my setup is ok.

For some reason I followed the (outdated I think) instructions linked above to manually update the firmware having forgotten that I actually earlier updated it by internet (which seemed to work). Then it disappeared on SLCAN never to return. Tried copter master, plane master, plane stable, copter stable. copter beta, plane beta.

The one that worked powers up with flashing white LEDSs and then goes solid green while the one that never worked just has alternately flashing white LEDS.

I have read everything here, tried all that I can. I have seen some others in the same spot I think. The real problem here is we have a device that must be on CAN to update. Can we not flash it another way? I see another connecter on the board. Otherwise I have effectively bricked devices – they may work as i2c devices. Not tried.

I do not think I can return these to RMRC at this point – I kept these on the shelf until I thought firmware was stable.


1 Like

In the exact same boat, i’ve tried every combination of MP and Ardu software along with the CAN GUI, different power sources, usb cables, and timing and still in the hung state. Pretty frustrating at this point.

We need an answer. We really need to know how to flash them without using SLCAN.

There has to be a way to force into bootloader mode and flash without going through SLCAN – it is obvious they are not flashed this way at the factory,

1 Like

Hi Marc. There Here 2 instructions are basically correct as is the firmware.

The process is correct the issues appear to be after performing the boot loader update people can’t get it to connect again to upload the firmware.

In my experience this is an issue between Ardu and MP version. For me I had this and it was just a case of messing with versions until I got it behaving.

I used mission planner beta and chose a daily build of copter or plane from mid 2019 and I managed in the end to get it to show and then flash the application.

SLCAN has been a little bit of a sod it seems to say the least and it’s had a load of changes as well that seem to have made things slightly unpredictable at times.

Please use mission planner beta and latest release Ardupilot

If you cannot get it working, I will manage a swap of hardware for you.

I am doing exactly that. MP Beta and Ardupilot Master, Stable, and Beta.

Can you share any method of flashing that does not involve SLCAN connection? I am pretty happy to try and fix this. I have never been unable to reflash a bootloader before.

As regards swapping hardware I can send it back to you. I am not in any great rush. I will try a few more times.

1 Like

So I need to go back to a mid 2019 version of Ardupilot? Is that your advice?

I have struggling with this for ages. Using the latest beta builds Mission Planner and Arducopter. My default COM usb connections have always been 115200. Noticed it is now listed as 57600 so changed to that. Downloaded the apj files from firmwares (Orange in my case) Could finally connect using SLCan Mode CAN1 but couldn’t update the bootloader or firmware. Finally saw the other bricked post - changed SERIAL3_BAUD from default 38 to 115 then update via internet and its working! In all the posts I have read I never saw that you manually need to change SERIAL3_BAUD
The Updating Here 2 firmware page needs this vital piece of info


Ian – thanks for the encouragement. It paid off and I finally got this working using Copter Stable and MP Beta. I am not sure what I did differently.

The moral of the story is to persevere with this.

1 Like

All is well that ends well. They are both working now. Just perseverance paid off. MP Beta and Copter Daily seemed to be the ticket.

I updated the bootloader manually and used the internet update for firmware update.

Edit – well it has gone again when i installed latest plane and now when i revert back to Copter Daily I cannot see either of them on SLCAN. Oh well. This is definitely not a hardware issue. I still think CAN is not stable – for me anyway. It makes little sense to do hardware swaps for anyone based in what I have seen. Just an FYI. I will circle back to this.

Final Edit. Copter Stable works, Plane stable does not and Copter Beta does not, and nor does Copter Daily. This may explain a lot of the issues people have been experiencing. It is buggy!

1 Like

Glad you had it sorted. The issue is SLCAN. It’s nice your updates actual CAN functionally works solid. But SLCAN is all over the place at times and it’s not even easily to reproduce working/not working.

Now your updated it should be solid in actual GPS though.

Glad I was able to help.

So this is a good point. Setup is a one time thing. The underlying CAN function does not, I gather, depend on The FC working in SLCAN passthrough mode.

SLCAN in MP and Ardupilot is still a WIP.

Sadly I am still having issues. Here is what is very weird – the environment that worked yesterday (Copter Stable and MP Beta) is not seeing anything on SLCAN. Tried Copter Nightly and Beta as well.

So since I have previously updated and allocated a node I thought I can just enable CAN and use GPS. Nope.
I set these params:

Am I an outlier and is CAN working well for most people with Here2?

These settings on Copter Beta, Nightly and Stable are still resulting in "No GPS’. Despite the GPS having solid Green lights after booting up with flashing white-blue lights.

So in my nightly conversation with myself in my UAVCAN nocturnal diary…

I took another Cube Black out of a plane. Flashed it to Stable Arduplane 4, using MP Beta, and Voila, the SLCAN worked again. I updated firmware again and allocated a Node ID (which I may not have done last time). Now this all works. I have CAN GPS on one Here2 unit.

But here is thing. There is no repeatable pattern to this. There simply is not. I can say that quite confidently. I am confident this GPS is good now. But I stumbled onto this.

My other Here2 is not responsive on SLCAN. So I have to just randomly keep trying. There is something up with SLCAN implementation. Maybe it is a bigger issue with older units. I think this should get some attention…

Hope this is all useful.

Edit. This may be useful info to @Michael_Oborne (if he can bear to read this thread). I was able to fix my last Here2 by connecting to the working Here2 by SLCAN and then unplugging it and plugging the unresponsive one. It immediately was recognized. I could set the NodeID and now it is working. I think this info is important. I think it is also important that both my units were not allocated a Node ID in the paramaters when I checked them after finally seeing them again on SLCAN-- I saw they had an ID originally (when I first was able to connect by SLCAN) so I thought it was ok. But the NodeID parameter was still empty. I am certain this was my issue.

Many others have seemingly had this same experience.