Here2 reset to defaults

After doing an update on my Here2 the LED’s are a constant white/purple. Is this bricked? Is it possible to reset to factory defaults. Approached RFDesigns about this but they don’t offer any support for Hex products sold by them.

Was it working before the update?

Did you follow this guide to update the Here2?
https://docs.cubepilot.org/user-guides/here-2/updating-here-2-firmware

It was flashing when I first plugged it in. After setting Cn_Driver_1 on an Orange Cube and I pressed the update link for over internet. Sorry I made the assumption that the internet download would give me the latest firmware. When I rebooted I just got white/purple solid leds. I had read the mentioned post but because I am using Mission Planner 1.3.7 and the instructions only mention the Black Cube and I brought the Here2 back in Feb 2020 assumed the pathway was more streamlined.
Is there anyway to reset to defaults?
Should add using copter 4.0.6

Had this running for over an hour. Is anything happening? Still have solid LEDS.

Looks like your Here2 is still on the bus.
Have you tried to update it again by clicking Menu>Update>yes>no(no beta)?

Otherwise, try to enter bootloader mode by flashing bootloader again
https://docs.cubepilot.org/user-guides/here-2/updating-here-2-firmware#step-10-flash-the-bootloader-updater
Then update the Here2 again

After deleting the drivers via Mission Planner several times Managed to reconnect with Here2. Tried Menu>Update>yes>no showed that it had updated. Still solid LED’s.
Also no luck with the second method of reflashing bootloader.
I can connect with Cube Orange Mavlink Com6 and Cube Orange SLCAN com9 but noticed when I reinstalled the firmware on the Orange Cube that it thinks it is on Com7?

This is the screen after completing the above steps.

First time been able to access parameters

Just tried 2 other Here2’s I have all work fine. Tried several times with the bootloader but no luck!

I can connect with Cube Orange Mavlink Com6 and Cube Orange SLCAN com9 but noticed when I reinstalled the firmware on the Orange Cube that it thinks it is on Com7?

COM7 may be the bootloader port because it is separated from mavlink/firmware port.

Can I have a picture of your Here2?
Was it working normally before updating? LED being solid white may be related to a hardware problem in LED, but it shouldn’t suddenly come out after a software update.
Are other functions such as GPS and mag still working?

No GPS connecting or Mag1. Now listed as missing

Was working - flashing green LED’s ages ago but I was always having trouble getting a completed Mag Cal. Only Mag2 is showing active now. Its behaviour seems to be changing - like a loose sensor? It has never been off the bench.

Cn_Driver_1 only turn on the canbus which allow can devices connecting.

You need to set up these parameters to get data from it

CAN_D1_PROTOCOL:1
CAN_D2_PROTOCOL:1
CAN_P1_DRIVER:1
CAN_P2_DRIVER:1
GPS_TYPE:9
NTF_LED_TYPES:231

https://docs.cubepilot.org/user-guides/here-2/here-2-can-mode-instruction

Can you try if other components are good? Also, open the case and toggle the switch to verify the connection. Make sure it is at CAN mode.

Protocol and driver, GPS Type NTF all set. As mentioned before my other Here2 works fine on this cube. Also have a Here which also works with GPS Type:1
Photo shows connection with i2C . instant white LED’s. Can I return this to the dealer?

White LED’s mean LEDs are powered but receiving no data. It could be faulty LED but I doubt it would become bad by update.
You may send it back for inspection