Here3 gps and fbwa mod error

I am working with Pixhawk cube orange and here3 gps. FBWA mod works fine without gps when I want to set flight modes. When I plug in Here3 gps it sends commands to servos like manual mode.
FBWA mode here 3

!

!

Here3 has nothing to do with RC signals…
Can you share your wire connections?

hello alvin,
A system outputs from a classic Vtail. I tried the links. There is no problem when Here3 is not connected. As soon as I connect it, a problem occurs in all modes.

I entered 65 as rc6_option and you can see the changes in FBWA mod RC channel signals after GPS on and off. video: https://youtu.be/APgiroHvIuc

Can you show me the Here3 connection?
Have you set it up properly?
You may also try to reflash the Here3 in UAVCAN screen in Mission Planner.

CAN-1 port Here3

Here3 I restarted but nothing changed. I tried so hard to solve this problem

Can you share a log showing the Here3 connect and affect the RC?

2021-07-18 18-51-49.tlog (1.7 MB)

Please share the dataflash log instead of telemetry log.

Also, did you recalibrate the system after plugging in the Here3? Maybe the GPS compass is not fused with EKF well?

Log data from my flights. It provides a deterrent against calibration. EKF seems to be working properly.


In your log looks like your autopilot is not tuned well. The achieved attitude is far from desired attitude in most of the times.

Also, you logs are all flight logs which contains too many real world factors. I can’t distinguish the RCout by autopilot or Here3.

Can you set up an independent ground test with only RC and Here3 involved?
Set LOG_DISARM to 1
Bring your aircraft to outside
Connect the Here3 and get the 3D Fix. Replicate the problem. Let it log the RC behaviour if it happen
Disconnect the Here3 and do the exact same thing as last step.
Share those logs.