Here3 gps ublox firmware issue

The U-Centre reports the firmware of the Here3 as SPG (it should be HPG). Even after updating firmware using the HPG firmware downloaded from Ublox (from https://www.u-blox.com/en/product/neo-m8p-series#tab-documentation-resources), the version that is reported is SPG

Another Here3 I own is working properly and U-Centre is reporting its firmware as HPG (it’s firmware was successfully updated using U-Centre and CAN passthrough as instructed in the manual)

I’ve tried updating firmware using multiple Pixhawk cube boards, as well as both legacy update and normal update mode.

Not sure where the issue is coming from. Would be glad to have a solution.

Did it show firmware update successful message in the update window?

Also, can you try to restart/reconnect u-center after flashing the u-blox firmware into it?

Thank you for your response.

Yes, it did show Update Success after updating firmware.

Regarding the restart/reconnect of u-center, should I do it before restarting the GPS module?

If it shows update success then its weird for the version information being not updated.

Restarting and reconnect u-center force it to reload the data it gets from chip. The u-center usually hold the previous loaded data in the field which may be confusing.
I think this is not what’s happening on you, but just to be sure.

After updating firmware, if I restart u-center it just doesn’t receive any data from the Here3. Even the packet console shows no messages from Here3.

However I managed to solve the issue. Not sure why but on setting the PassThrough parameter on MissionPlanner to 1 and then doing a firmware update resolved the issue. Now the UBX-MON-VER is showing EXT CORE and correct firmware.

This is really confusing as my other Here3 module updated with PassThrough set to 2.

Thank you for your assistance Alvin. Hopefully this issue won’t occur again.

As written in the guide, you should set passThrough to 1 for parameter review
https://docs.cubepilot.org/user-guides/here-3/here-3-manual#2.-here3-u-blox-chip-firmware-update

Maybe the parameters were not updated successfully without the correct passThrough value.

That could have been the issue. Thank you for the help Alvin.