Here3 No Fix

I am using Here3 with Cube Orange on ADS-B carrier board. I am using APM Copter 4.05. I have performed the setup of parameters according to the manual in the Cubepilot site. It’s just the basic setup with Here3 connected to Can1.

After restart, I have the flashing blue LEDs but no satellites and no fix.

Flashing or breathing blue… is stuck in can bootloader mode.

Double check all your can configuration



I haven’t changed these:


Thank you Philip. A friend dropped by and I left the Cube / Here3 connected to USB for several hours. When I returned, it was flashing green with 6 sats (indoors near a window). I never had trouble connecting to satellites in this location using here2.

I took two similarly equipped vehicles up to my rooftop deck, one with Here2 the other with Here3. I set them up right next to each other. After say 20 minutes the Here3 maxed out at 10 sats and HDOP 0.9 while the Here2 had 14-15 stats with HDOP 0.7. I tried this test with 2 different Here3s with the same result. Is there a known explanation for the difference?