Here4 not visible on SLCAN after Firmware Update

We wanted to test the Here4 GPS and run into some issues. We updated the GPS over the mission planner dropdown menu (update over internet, to V1.14) and now both LEDs just have a permanent white. Neither with MP nor with the DroneCan GUI Tool was I able to detect anything. I also tried both CAN buses, with the CAN_SLCAN_CPORT config.
Interestingly, the compass of the Here4 is still recognised over DroneCan. And the GPS is visible within the “temp” menu.
I have the same issue on two Here4 modules.
How can I fix them?

@mm-dbr which Ardupilot firmware version are you running? also can you connect over MAVLink CAN1 or MAVLink CAN2 instead to see if Here4 shows up there. Please also share the log with LOG_DISARMED set to 1 on Cube, and Here4 connected

Hi Siddarth
Thx for reaching out so quickly.
We are using Firmware 4.4.4. MAVLink CAN1&2 do not work either.
1 01-01-1970 01-00-00.bin (778 KB)
This is the logfile from a short startup, let me know, if i should do anything specific.
My current test setup looks like this

Another Question:
With the Here3 we are able to have the GPS connected to the cube and listen to the GPS data in parallel over UART with our flight monitoring unit.
I’ve read that only 3.3V on the I2C activates the Here4 to communicate over UART. How can we enable an additional GPS data output on the Here4? I have not yet found a description of all the other config parameter of the Here4.
For your info, we still have to additional Here4 that were not updated to V1.14, only to V1.13 and they still work perfectly fine.

@mm-dbr so the issue in your setup is that the hardware CAN index doesn’t match with software CAN index. Please connect to CAN2 connection, I believe it should work there.

Hi Siddarth
I tried both Here4 on both CAN bus 1&2 and they still don’t boot normally. Is the permanent white LEDs really a connection issue? I suppose the Here4 should boot up normally regardless if communication is possible or not, or am I wrong?

@mm-dbr you are correct, the Here4s should boot normally. If the LEDs are solidly on white, that potentially means that the firmware and bootloader are not running at all. It is quite unusual for the unit to be in that state after update.

Was the unit disconnected mid-update by any chance?

Hi Siddarth
Both modules magically left their weird white LED state and can be reached over mission planner again.
Unfortunately, I was using a cube with an outdated firmware version during my testing and that was the issue.
My colleague that updated the modules and caused the constant white LEDs, was using the firmware, when he was not able to connect anymore. It makes no sense to me, how he wasn’t able to connect anymore and somehow it works again. The only thing we changed in the parameters was setting the CAN_SLCAN_CPORT to 0 instead of 1 or 2.
Nevertheless, we still have another question regarding the UART Configuration. Could you please help us there as well? The goal is to have the Here4 connected to the cube via DroneCAN and listen to the GPS data in parallel over UART.