HereLink 1.1 Air Unit Ethernet Setup

Hi,

I’m currently experimenting with a HereLink 1.1 system and trying to get access to a device which is connected to the ethernet port of the air unit. My goal is to have a custom app running on the GCS that is able to communicate with the device connected to the ethernet port of the air unit via network.

I have set up the GCS so that it is paired with the air unit and I already managed to use adb to access the air unit (PC → GCS via WiFi → air unit) and verify that the bridge network adapter is there and that I can reach the endpoints (192.168.144.10 and 192.168.144.11).

My setup on the air unit side looks like this:
air unit → USB to ethernet adapter → Laptop

The network cable is wired up like this, I hope this is correct:

The Laptop is disconnected from all other networks (e.g. WiFi) except the USB adapter. The adapter network show up as being connected and the adapter itself has both LEDs (connection and traffic) lighting up, so I assume my cable is working.

Now I would have expected the local IP of the Laptop to be in the range of the bridge network (192.168.144.x), but it gets an auto-assigned IP (via DHCP) in the range of 169.254.41.x. I also cannot manually set an IP address.

I tried scanning the network to find the air unit, but I wasn’t able to. And now I’m kind of stuck with the following questions:

  1. How can I access the air unit from the Laptop?
  2. More importantly, how can I access the Laptop from the GCS?

Thanks in advance!

2 Likes

Some more notes and observations:

We’re experimenting with this for a while now with multiple people involved and are pretty much stuck. We were trying to establish a connection a) between the laptop and the air unit via the makeshift ethernet cable + USB adapter and b) between the laptop and the GCS via the ethernet bridge. Neither is working so far.

We setup the network for a) in a way that both ends have their dedicated fixed local IP address (192.168.145.x/24) but both devices still were not able to ping each other (Laptop <-> air unit).

I’ve tried the same setup with the laptop and another PC to make absolutely sure the USB adapter does work in that scenario: I directly connected the laptop with the other PC via the USB adapter and a normal ethernet cable, set the local IPs and tadaa… it worked flawlessly.

So now there are two possibilities:

  1. My makeshift network cable doesn’t work (which is unlikely because the LEDs on the adapter are lighting up and the network monitor shows packages being sent and received).

  2. The air unit blocks traffic or somehow needs some extra configuration.

Again, any hint would be highly appreciated!

there is no dhcp provided by the herelinks, you need to manual set an ip address inside the range
eg 192.168.144.50 subnet mask 255.255.255.0
this will put you within the ip range of the airunit and gcs unit, so they are accessible from the airunit ethernet port

1 Like