Herelink Air Unit Firmware Corruption

I have had issues on 3 seperate units within the last 3 weeks of the firmware on the Herelink Air Unit corrupting, twice in less than an hour today. During booting the drone the Herelink Ground station will say it is paired to the Air Unit but is not connecting to QGC on the Ground Station. So far I have narrowed down that this only happens on boot, and has never done this during flight. If I wipe and re-flash the firmware on the air unit and re-pair the air and ground units, I can regain connection to QGC on the herelink ground unit.

Currently the air unit is powered by a 12V/3A PDB-BEC that shares power with 4 LED Lights that pull 4.8W max, so I do not think it is a power issue, but correct me if I am wrong.

It seems like this only became a problem after updating to the newest firmware on the air unit and hand controller.

Has any one else had this issue? I really need a fix for this.

Same problem here. My last 2 air units behave with the same way. Working after re update from pc and pair. After 2 or 3 boots losing telemetry. Rc working.
Any permanent solution?

What is the version of QGC you are using here ? Is it Beta or stable ? I have problems too but with stabilized mode switching to manual mode . Never had such a issue with the previous QGC version !!


Currently using the herelink, but inside of the QGC App on the herelink, says the version is:

Development herelink-v4.0.8-dev:caeaf60 2021-07-29 16:30:33 +1000 64 bit

Not sure why it says dev herelink, as there has been no customizations done.

Like I said it is only happening during boot for me.

Using Firmware FRU01200409

Mine is BRU

FRU is the latest correct?


Are there any more cases like this out there? Something hardware that could be making this happen?

No. You are not in the latest firmware. Strange thing is that your QGC on the Herelink is the latest version… how did you manage to do that? :wink:

I just updated the herelink out of the box :slight_smile:

I will try to update the firmware on the controller, as the latest firmware is on the Air Unit.

When downloading the latest firmware on my herelink using the fastboot and flasher_win.exe it says the latest firmware is FRU01200409. I will try to update it anyways.

I am using the video guide from Mad’s Tech referenced on Cube Pilots docs.

Oh wow. I think this is on me entirely. I will update if there are still corruption issues. Thanks!

Okay I updated to the latest BRU and rebooted 4-5 times and have no connection to QGC on the herelink again. I do have SBUS control and the ground station is still paired to the air unit, but no telemetry or parameter download to QGC on the herelink.

LED2 is on but LED1 is not.

Air unit is on AAU01210729

Same thing also for me. 2 air units with the same behaviour. Sbus connection is fine but not telemetry. Is it possible to be cube latest firmware issue? Because I run multiple herelinks with latest firmware but with older arducopter firmware.

I am currently on Arducopter 4.1.1 Which firmware are you using? Do you think its only happening with the latest firmware?

I am not sure if its cube’s firmware. I will try tomorrow to downgrade firmware and test it. But the problems start when I used firmware 4.1. May be its coincidence.

I jumped from 4.0.7 to 4.1.0 and I don’t remember having these issue prior. I will downgrade mine as well and get back with you tomorrow. Mine has corrupted 5 times today through multiple reboots. I have also noticed it doesn’t corrupt as often if I do not close out of QGC.

We have experienced the same issue…pairing stays, but cannot get any vehicle connection. We have to re-flash the air unit and then pair again and it will work for a little while, but then goes back to no vehicle connection in our app. I have tried downgrading the Cube firmware with no difference. We have done it over 4 times with the same drone. Looking for an answer to why this is happening? We are running AAU01210729 firmware on our air units.

1 Like

Nope. I think BRU is the latest :slightly_smiling_face:
I think my version dates are from Sep 2021 .

Did you upgrade your Airlink unit . V. important for the Herelink system to work

Yes this is the latest firmware.

Is everyone having this issue using a cube orange