Herelink Air Unit Firmware Corruption

Hi,
Actually I am running on the stable release. I never tried the Beta version . The stable is good to go except you have sometimes the video stream freezing while recording but not always…The video switches ON very quickly. Well my HDMI is coming from a Raspberry Pi 3 A+ companion computer

Hi,

Yes it will ask for product KEY becos it is completely a different firmware version . Its no big deal.

I always update via PC

@austin relieved to hear this problem is happening with other people. We’ve had to reflash our air unit twice now due to telemetry issues. Basically the exact same problem described by everyone else. Running an Orange Cube with herelink controller, air unit, cube, and mission planner/QGC all updated within the last 2 weeks. Also updating the air unit via PC

The telem connection problem can happen. But mostly easy to recognize because the faulty units do not connect at all.
Having them malfunctioned occasionally is strange.

This LED behaviour displays there are issue on telem connection.
That may be due to bad internal connection with an IC. But, again, being able
to temporary fix it with software update is strange.

Can you try to create a bug report?
https://docs.cubepilot.org/user-guides/herelink/herelink-user-guides/generate-a-bug-report

Thank you, Alvin.

Are we sure this is a possible hardware problem? We have been running the exact couple of units with the older Herelink Air and GCS software and never had this problem for hundreds of flights and now see it all the time. We have to reflash the Air Unit to get telemetry back. It is the same Air Unit, but now the new software.

@Alvin I will create a bug report but can confirm with what other people are reporting - Flash airunit > connect and everything is setup and working > boot a couple times with no issue > come back the next day and boot up the drone results in only LED1 not lit > reflash air unit and everything works again. Since you ackowledge the fact that a software update will solve the issue is strange, could this be a airunit firmware problem?

can i get some bug reports for the air unit when its NOT working. need to track down what is going on here

Yes, let me try to do that for you.

Thank you, Michael.

Can others on here do it as well, please?

Here is the air unit bug report pulled after no vehicle connection.badconn.zip (512.3 KB)

Edit: @Michael_Oborne
Not sure this is what you might be looking for. I did this (now that I think about it with the handheld ground unit off). Should I of had it on when doing this bug report? If so, I can do another one tomorrow. I went directly into the air unit to grab it.

I have not been able to reproduce it after downgrading firmware to 4.0.7, I will upgrade the firmware after these last few jobs and try to recreate. Wasn’t there a change to MavFTP on the 4.1.1 update? Could this have anything to do with the connection?

@Michael_Oborne I was able to reproduce after the 7th or 8th boot. I am using Cube Orange on 4.0.7, so it cant be a firmware issue. However this one is odd.

The Herelink GCS lost connection to telemetry. I rebooted a couple of times and it did not reconnect. I then generated a bug report on the Herelink GCS. Then for some reason I thought I may could generate from the Air Unit. I plugged in the Air Unit and ran “apd bugreport” it prompted “looking for device”. So unplugged the air unit and Reopened QGC on the Herelink, and in the middle of pulling the bug report the telemetry connected back to QGC on the Herelink. this is the First time it “fixed itself”. Anyways I have both bug reports:

The first one - no telemetry
bugreport-N2G47J-2021-11-30-17-49-20.zip (1.2 MB)

The Second - during reconnection
bugreport-N2G47J-2021-11-30-17-53-11.zip (1.1 MB)

Hope this helps.

ive created a new air unit firmware that should resolve this
please try updating the air unit from the GCS unit

Hello :wave: All our herelink units are runing the latest firmware and this problem just doesn’t go away, actually we’ve been using herelink since the beta versions and as time passes this issue is more and more common. Upgrading the air unit from the GCS unit doesn’t seem to make any difference. Is there a specific way in which we need to upgrade the herelink? How can we help?

please try updating the air unit from the GCS unit
ie herelink settings > air unit > and the 3 buttons across the top

@Serch_c

This solution has worked for me for the passed month. Make sure your Herelink Ground Station is updated to the latest firmware. You will have to plug it in via USB and use the script mentioned in cubepilot docs.

Make sure your Ground Station is connected to wifi, then follow the steps Micheal said to do. Make sure to download the firmware this way. at the end of the steps, the online version and local version should match.

Thanks for the fast reply, I’m pretty sure we’ve done that, but I’ll check with my team. Is there a way to confirm the firmware version of the air unit after the flash? Or maybe is there a way to manually download, select an install a specific firmware to the air unit? That would save a lot of trouble.

Thank you, I´ll give it another try. I asked Michael but maybe you know. Is there a way to confirm the firmware version of the air unit after the flash?

Once you reboot the online version of the air unit should match the local version of the air unit. Herelink settings → air unit, will show you the online version (most recent) and local version (what is on the unit currently)

1 Like