HereLink-Beta

#23

devicemanager
adbdevices

here is a couple of screenshots.

#24

C:\Users\Pitchup\Desktop\remo\ is the path where the android tools and firmware are contained

#25

Ok, can you try installing the driver from this link and try again: https://developer.android.com/studio/run/win-usb

#26

thanks for your help but still the yellow triangle showing in device manager

#27

can you try adb devices again from the path where you extracted android tools and firmware.
And check if the device shows up now.

#28

Nothing found. On the instructions it says to download and install android tools. There is no install for just the android tools. Should I install android studio?

#29

No, its not related to that, it seems like a driver issue. I guess you already restarted your system, just in case. Also please share which Windows version are you on?

#30

yes restarted system. using windows 7

#31

I have developer options on and usb debugging on.

USB was set to CHARGE THIS DEVICE and it showed optimus in the device manager with the yellow triangle.

If i change USB to Transfer files then it says ADB Interface in the device manager with the yellow triangle but I still cant update driver or find any devices in the CMD prompt

#32

Under normal circumstances I whole heartedly agree, however I was hit with early onset dumbass and was trying to update the air unit with the remote script even though I knew better🤪

Cheers RB

1 Like
#33

Does anyone successfully setup the scroll wheel ?

#34

I will try if I can get this working on Windows 7 system, and get back to you.

BETA updating problem?
#35

Great. I will bring my mac in tomorrow and have a go with that as well! Thanks for your help

1 Like
#36

Please check this example video


adb seems to work after installing the driver as shown in the video.
#37

It Worked with your video! thank you so much!

#38

Hi All,

I’m following the instructions for flashing the Herelink with Ubuntu and I am unable to run “./flash_all_except_data_storage.sh” due to the error: “Product unmatch with optimus”

Please advice, thank you!

#39

now one more problem, still cant see any movement on the gimbal wheel

#40

Needs to be done for gimbal wheel to work
https://docs.cubepilot.org/user-guides/herelink/one-time-setup

#41

I actually tried that wheel calibration and the joystick calibration. It made my joysticks stop working. However flashed the controller again with flash_all and now have all controls including the gimbal wheel. Hopefully a test flight tomorrow!

Thanks for the help guys

1 Like
#42

Has anyone who has updated managed to get video?