HereLink-Beta

#1

The Wiki is a work in progress, but here is an outline of how to update your Beta HereLink to the latest Beta firmware.

Any questions on the process, please add here.

https://docs.cubepilot.org/user-guides/

Thank you to Siddharth and the rest of the HereLink team! It has been a long journey, but it’s finally time to get this software out there, and get more hardware shipping!

5 Likes
Beta 2 information update about the April Delay
#2

Is Solex in this release?

Looking at it no but lots of nice improvements :slight_smile:

#3

No Solex yet, this sets up the backend for Solex. One step at a time

1 Like
#4

Cool beans :).

#5

Hello,
I just update Remote Unit and AirUnit and everything looks fine except I can’t get them pair.
Before upgrade everything works fine.
Any guess?
I do the pairing procedure but fails every time.

#6

@sidbh

#7

Did you use flash_all_except_data script?

#8

The Air Unit firmware has only the flash_all_except_data_storage and not the flash_all_except_data script.
If you mean this I have done it and after the update its shows me 2 folders, one DCIM and another flight_log folder. Correct?

#9

Can you try updating using flash_all script instead?

#10

Thank you.
Now everything works fine

#11

really excited to try this. ive extracted the Air Unit folder fine but the Remote unit tells me its corrupt. ive tried a different computer and extraction program any ideas? using windows 7

#12

@sidbh How to share video over network. and How to configure Mission Planner on desktop.

#13

It appears reading release notes : set up android hotspot from from herelink(probably set up for 5GHz) then with other device log into it.

#14

Just a quick question. I assume the Air end need to be external powered when updating.

#15

https://docs.cubepilot.org/user-guides/herelink/firmware-releases#v-0-2-2

#16

Doh missed that twice.

Sorry seen it now.

#19

Rather than removing it, just posting how you solved it can help others…

#20

@Stelios, @sidbh,

Same trouble here. After firmware update with ‘flash_all_except_data_storage.bat’ files
on remote controller + air unit, i was unable to pair.
I updated one more time the remote controller with ‘flash_all.bat’, and nothing changed. But after re-flashing the air unit with the ‘flash_all.bat’, the pairing procedure worked.

#21

solved my first problem. But now when i enter the CMD prompts nothing happens. When I look at device manager the Herelink shows as OPTIMUS with the yellow triangle warning me it cannot find a driver.

#22

@Cameron_Sweden Can you execute adb devices from CMD Prompt and share the result?